Opened 8 years ago

Closed 8 years ago

#4346 closed defect (fixed)

TA168 unstable on OS21 12.1.0

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Gerald Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Hello.

I have a class set of XO-1 laptops running the latest 12 build.
I am also running TurtleArt version 168.
In Turtle Art, the devices are freezing quite often.�
I have turned off the wireless cards on all of them, thinking the problem was related to noise. This made no difference.
I would appreciate any support with this. I really want to be using Turtle Art, but my students keep losing work in the restarts.

Thanks.
Gerald

Attachments (3)

shell.log (54.5 KB) - added by tonyforster 8 years ago.
org.laptop.TurtleArtActivity-1.log (2.6 KB) - added by tonyforster 8 years ago.
TurtleArt-169.xo (3.0 MB) - added by walter 8 years ago.

Change History (13)

Changed 8 years ago by tonyforster

Changed 8 years ago by tonyforster

comment:1 Changed 8 years ago by tonyforster

Walter, do you need more logs? I didn't see any old logs in var/logs for example

comment:2 Changed 8 years ago by walter

There is definitely a memory leak. Where, I don't know yet. It only seems to occur then running with the blocks overlaid on the canvas (running with blocks hidden seems to be OK). I has suspected something with the highlight code, but eliminated that possibility (while also making a few improvements to that code).

I suspect that this is a problem with all systems, not just 12.1, but perhaps due to the way 12.1 uses memory, it manifests itself more quickly there?

Will keep looking. Meanwhile, note that if you stop the program (by typing Ctrl-q) eventually it will exit, preserving your work. You may have to wait 10-15 minutes, however.

comment:3 Changed 8 years ago by Gerald

  • Cc Gerald added

comment:4 Changed 8 years ago by walter

Still running some more tests, but I think the memory leak was regarding pango layout in sprite.py. This patch [1] seems to fix the problem.

[1] http://git.sugarlabs.org/turtleart/mainline/commit/c3b81450372cff7b7bd5649ea4f2cbfe0df70c7f

comment:5 Changed 8 years ago by walter

Probably this is a duplicate ticket to #3291

comment:6 Changed 8 years ago by tonyforster

Ran V169 for some hours on 2 laptops
XO-1 12.1.0 ran ok
XO-4 13.1.0 os20 failed
ta log:
1356299813.515719 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message

self._handler(*args, kwargs)

File "/usr/lib/python2.7/site-packages/sugar/presence/connectionmanager.py", line 89, in status_changed_cb

self._connections_per_account[account_path].connected = False

KeyError: dbus.ObjectPath('/org/freedesktop/Telepathy/Account/salut/local_xmpp/account0')
Terminated by signal 9, pid 1058 data (None, <open file '<fdopen>', mode 'w' at 0x1771338>, 'fc7750e84d20290f95242c4fe2c1f85a162c9255')

comment:7 Changed 8 years ago by walter

Sorry about that. I sent an update later (I guess only to Gerald) with the XO4 patch (attached here too).

Changed 8 years ago by walter

comment:8 Changed 8 years ago by tonyforster

I think I did use the second of 2 versions: "Sorry. Please use the attached version instead." Was there a third? If there wasn't a third, what was the patch and I will check its applied.

comment:9 Changed 8 years ago by tonyforster

I think the version I tested contained up to

Walter Bender committed 1d9196bf on December 23, 2012 17:51

make HELP_MSG attribute

comment:10 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.