Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#434 closed defect (notabug)

lists.sugarlabs.org seems to be skipping emails!

Reported by: tomeu Owned by: krstic
Priority: Urgent Milestone:
Component: infrastructure Version:
Severity: Critical Keywords:
Cc: bernie Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

this has already happened once to me (that I know of) and also just happened to Paul.

The email I didn't received was

http://lists.sugarlabs.org/archive/sugar-devel/2009-February/011631.html

and the one that Paul didn't received was

http://lists.sugarlabs.org/archive/sugar-devel/2009-February/012236.html

I'm a bit worried about it, could someone give a look into why this is happening?

Change History (7)

comment:1 Changed 12 years ago by garycmartin

Just to chime in and confirm on this one, sugar-devel email seems to be all over the place in terms of delays the last few days – I've read most of the end of threads before seeing the original posting, perhaps ~12-24hrs between. I think I read most of the "Future of Rainbow + Sugar?" thread in reverse ;-)

comment:2 Changed 12 years ago by bernie

  • Owner changed from bernie to krstic
  • Status changed from new to assigned

Ivan, any idea?

Perhaps we need to increase concurrency on the outbound mail queue? sugar-devel has some 600 subscribers, I wouldn't be surprised if Postfix fell behind on a busy day.

comment:3 Changed 12 years ago by bernie

  • Cc bernie added

comment:4 Changed 12 years ago by tomeu

Not sure Gary is having the same issue as described in the description of this ticket.

Seems like mailman decides not to forward an email to someone who is already in the list of recipients for that email, and for some reason the email also doesn't reach that person by normal means.

Can this have anything to do with SLs' setup or is a problem of each of the people who are seeing this?

comment:5 follow-up: Changed 12 years ago by bernie

  • Resolution set to notabug
  • Status changed from assigned to closed

Ok, so I know what's causing it, and it's not a bug.

Mailman has an option "nodupes", aka "Avoid duplicate copies of messages?". It was enabled by default for new subscribers on all our lists.

I changed the default, but each subscriber needs to go change it in their personal settings to get this fixed. People who do not sort mailing lists into folders might even prefer it this way.

comment:6 in reply to: ↑ 5 Changed 12 years ago by tomeu

Replying to bernie:

Ok, so I know what's causing it, and it's not a bug.

Mailman has an option "nodupes", aka "Avoid duplicate copies of messages?". It was enabled by default for new subscribers on all our lists.

Ok, but why nor Paul nor me received a copy of a message that was addressed to us as well as to sugar-devel?

comment:7 Changed 12 years ago by krstic

Tomeu -- can you clarify a bit; when you say you didn't receive a copy of the message, do you mean you didn't receive it *at all*, or just that you didn't receive a copy through the list?

Note: See TracTickets for help on using tickets.