Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4331 closed defect (fixed)

Journal ListView: buddies not shown

Reported by: erikos Owned by: manuq
Priority: High Milestone:
Component: Sugar Version: 0.98.x
Severity: Major Keywords: regression, r+
Cc: humitos, erikos Distribution/OS: OLPC
Bug Status: Assigned

Description

After having shared an activity with another learner this is not indicated in the list view. The detail view does show the buddy (even so slightly un-aligned).

This is a regression over 12.1.0

Attachments (6)

0001-Journal-list-view-display-buddies-again-SL-4331.patch (1.4 KB) - added by manuq 10 years ago.
Patch.
1210_buddies.png (80.3 KB) - added by erikos 10 years ago.
12.1.0
131_buddies_2.png (79.0 KB) - added by erikos 10 years ago.
13.1.0 first
131_buddies_3.png (77.4 KB) - added by erikos 10 years ago.
13.1.0 second
0003-Journal-list-view-use-one-column-for-each-buddy-to-g.patch (1.7 KB) - added by manuq 10 years ago.
Patch for the buddy wrong size in the list view.
0001-Journal-list-view-display-buddies-again-SL-4331.2.patch (1.4 KB) - added by manuq 10 years ago.
v2 - remove else conditional as per erikos feedback.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by manuq

  • Owner changed from erikos to manuq
  • Status changed from new to assigned

comment:2 Changed 10 years ago by manuq

  • Keywords r? added

Changed 10 years ago by erikos

12.1.0

Changed 10 years ago by erikos

13.1.0 first

comment:3 Changed 10 years ago by erikos

In the patch you do not need the else clause, as you have a return in the if statement.

Now we need to fix the spacing, attached are screenshots from 12.1.0 and 13.1.0 with one and two buddies.

Changed 10 years ago by erikos

13.1.0 second

Changed 10 years ago by manuq

Patch for the buddy wrong size in the list view.

Changed 10 years ago by manuq

v2 - remove else conditional as per erikos feedback.

comment:4 follow-up: Changed 10 years ago by manuq

Pushed ed18662f and b496eecd but leaving it open because Erikos was seing an issue.

comment:5 in reply to: ↑ 4 Changed 10 years ago by humitos

  • Cc humitos erikos added
  • Keywords r+ added; r? removed

Replying to manuq:

Pushed ed18662f and b496eecd but leaving it open because Erikos was seing an issue.

@erikos: What issue did you see here?

comment:6 Changed 9 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:7 Changed 9 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.