Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#4330 closed defect (fixed)

Journal: start editing unwanted entry

Reported by: erikos Owned by: erikos
Priority: High Milestone: Unspecified
Component: Sugar Version: 0.98.x
Severity: Major Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Steps to reproduce:

  • open an Activity (e.g. Log)
  • leave it open and now open a second one (e.g. Memorize)
  • close the second one
  • go to the Journal

---> both will have the correct order

  • wait one or two minutes
  • now resume the first activity
  • then go back to the Journal and directly try to go to the detail view of the second activity (Memorize)

---> the view is updated and since the first activity (Log) has been accessed just now it will be updated and moved to the top of the Journal but already when the Journal is shown, so when you tap quickly you likely will go to the detail view of Log instead of Memorize

Change History (7)

comment:1 Changed 7 years ago by erikos

Not a regression, so I will keep it in the 1.0 milestone.

comment:2 Changed 6 years ago by dnarvaez

  • Bug Status changed from Assigned to New

comment:3 Changed 6 years ago by dnarvaez

  • Milestone changed from 1.0 to Unspecified

comment:4 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:5 Changed 5 years ago by godiard

  • Priority changed from Normal to High

comment:6 Changed 5 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Show a wait cursor while the journal is updatinga - Fixes #4330

Changeset: 92e7069c7d75432000079b429571950d2009cb92

comment:7 Changed 5 years ago by Gonzalo Odiard

Show a wait cursor while the journal is updating - Fixes #4330

Changeset: 56be4aca26e0d7c678b2b223a8fcbe71477f7128

Note: See TracTickets for help on using tickets.