Opened 8 years ago

Closed 8 years ago

#4316 closed defect (fixed)

TA file fails to resume

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

XO-4 OS17 TA168
The following ta file wont resume

0, ["start", 2.0], 195, 140, [null, null?,
[1, "sound", 274, 371, [4, null]],
[2, "volume", 632, 372, [null, null]],
[3, ["forever", 0], 195, 337, [null, 4, null]],
[4, "print", 213, 371, [3, 1, null]],
[5, "isheapempty2", 295, 259, [null, null]],
[6, 0, 0, 0, null], [7, "forward", 552, 445, [null, 8, null]],
[8, ["number", 100], 644, 445, [7, null]],
[9, 0, 0, 0, null], [10, 0, 0, 0, null], [-1, ["turtle", "Yertle"], 0.0, -43.0, 0.0, 0, 50, 5]]

Sorry, can't copy the log just now, I think that the clipboard has broken the frame in OS17

Change History (7)

comment:1 Changed 8 years ago by tonyforster

tawindow.py line 3493
object nonetype has no len()

comment:2 Changed 8 years ago by walter

I've not been able to get any activities to launch on os17 :( But I get the same error on F17 running turtle from GNOME. Investigating.

comment:3 follow-up: Changed 8 years ago by walter

Looking at this ta program, I wonder if it ever resumed, i.e., I don't think this is a regression.

[6, 0, 0, 0, null],
[9, 0, 0, 0, null],
[10, 0, 0, 0, null],

I am not sure how this can occur. But I can work on a workaround.

comment:4 in reply to: ↑ 3 Changed 8 years ago by tonyforster

[6, 0, 0, 0, null],
[9, 0, 0, 0, null],
[10, 0, 0, 0, null],

I am not sure how this can occur. But I can work on a workaround.

Don't know. Maybe from a plugin?

comment:5 follow-up: Changed 8 years ago by walter

Added a check for loading empty blocks [1] that seems to handle this case. Still be interested in finding out how these empty blocks are being created to begin with.

http://git.sugarlabs.org/turtleart/mainline/commit/b0a9e840b309b116d01c136bbcf63e37f19cecdf

comment:6 in reply to: ↑ 5 Changed 8 years ago by tonyforster

Replying to walter:

Added a check for loading empty blocks [1] that seems to handle this case. Still be interested in finding out how these empty blocks are being created to begin with.

thanks, applied patch, fixes bug ok, I was hoping that looking at the ta code would jog my memory about the saved file, it doesn't look like I was messing with plugins when I last saved, at least one nul block looks like it was a flow operator

comment:7 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.