Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4315 closed defect (fixed)

Transfer palette not themed correctly and missing some information

Reported by: garycmartin Owned by: erikos
Priority: Normal Milestone:
Component: Sugar Version: 0.98.x
Severity: Unspecified Keywords: regression, 13.1.0, r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The Transfer palette is not correctly themed, and missing some information (the transfer size). See attached animation of how the palette looked in release 12.2.0, Sugar 0.96.2, vs. the current 13.1.0 build 16.

Attachments (3)

frame_transfer_palette_theme_original_vs_current.gif (18.9 KB) - added by garycmartin 8 years ago.
palettes.patch (9.1 KB) - added by erikos 8 years ago.
first patch to move the transfer Palettes to the custom style
0001-Filetransfer-fix-the-incoming-outgoing-transfer-Pale.patch (10.8 KB) - added by erikos 8 years ago.
Filetransfer: fix the incoming/outgoing transfer Palettes

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by dsd

  • Priority changed from Unspecified by Maintainer to Normal

comment:2 Changed 8 years ago by humitos

  • Owner changed from manuq to humitos
  • Status changed from new to accepted

Changed 8 years ago by erikos

first patch to move the transfer Palettes to the custom style

Changed 8 years ago by erikos

Filetransfer: fix the incoming/outgoing transfer Palettes

comment:3 Changed 8 years ago by erikos

  • Component changed from sugar-artwork to sugar
  • Keywords r? added
  • Owner changed from humitos to erikos
  • Status changed from accepted to assigned

comment:4 Changed 8 years ago by manuq

Excellent Simon.

The only thing I notice it that the progress bar is not being updated with the palette open. Tested with a 11 MB file. If I dismiss the palette and I open it again, the progress bar is correctly updated, but not if I left it open.

comment:5 Changed 8 years ago by erikos

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

It looks like the "progress bar not updating" issue was present in 12.1.0 as well, so I pushed this one for now: master=c6e19b4df9e8c1a4216aa09b9c579b43da9684d2, 0.98=2b02239b40ae653f91c5eda32af06798a428e0d1

Opened #4437 for further investigations.

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.