Opened 7 years ago

Closed 4 years ago

#4310 closed defect (fixed)

Sometimes the frame gesture stops working

Reported by: erikos Owned by: greenfeld
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.98.x
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Reported by Gary and Simon. No concrete steps to reproduce yet. We have to stress test and find out what is causing it.

Sam, can you help us finding concrete ways to reproduce this?

Change History (8)

comment:1 Changed 7 years ago by erikos

  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Major

comment:2 Changed 7 years ago by erikos

More details:

  • I have used the frame gesture to reveal/hide the Frame several times
  • then at some point, I can not use the gesture anymore to reveal the Frame
  • I can use the Frame key on the keyboard or the 'move-mouse-in-corner' to reveal/hide the Frame fine
  • switching views/activities or switching to use the mouse for a while does not bring the gesture back
  • Sugar is operational otherwise in the meantime
  • reboot brings the gesture back working

comment:3 follow-up: Changed 7 years ago by greenfeld

One way to cause the frame gesture not to work seems to be:

  1. Move the mouse to a corner to make the frame to appear.
  2. Try to use the frame gesture to make the frame disappear. It won't work even if the mouse is moved out of the calling corner.

Personally I think this still should make the frame go away even if the mouse originally caused the frame to appear.

comment:4 in reply to: ↑ 3 Changed 7 years ago by manuq

Replying to greenfeld:

One way to cause the frame gesture not to work seems to be:

  1. Move the mouse to a corner to make the frame to appear.
  2. Try to use the frame gesture to make the frame disappear. It won't work even if the mouse is moved out of the calling corner.

Personally I think this still should make the frame go away even if the mouse originally caused the frame to appear.

Tested in XO-4, os22: the gesture does make the frame disappear.

comment:5 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:6 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.98 to Unspecified

comment:7 Changed 6 years ago by dnarvaez

  • Bug Status changed from Assigned to Unconfirmed

comment:8 Changed 4 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

0.107.1 fixed one cause of this symptom; a request to toggle frame was ignored if it happened while the frame had not completed animation, and the animation had a few steps in it near the end where nothing appeared to be happening.

Closing. Please re-open if it reproduces now.

Note: See TracTickets for help on using tickets.