Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4304 closed defect (fixed)

Journal detail view: style favourite button correctly

Reported by: erikos Owned by: humitos
Priority: Low Milestone:
Component: Sugar Version: 0.98.x
Severity: Minor Keywords: regression, r+
Cc: manuq, erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

At the moment the button does have a grey outline in active mode. It should look like the favourite button in the list view.

Attachments (6)

favorites-grey-outline.png (16.5 KB) - added by humitos 8 years ago.
Screenshot comparing both
sugar-artwork.patch (1.1 KB) - added by humitos 8 years ago.
sugar-toolkit-gtk3.patch (1.4 KB) - added by humitos 8 years ago.
sugar.patch (3.0 KB) - added by humitos 8 years ago.
0001-Journal-details-view-Style-KeepIcon-SL-4304.patch (3.7 KB) - added by manuq 8 years ago.
Shell patch based on humitos one.
0001-Journal-Details-View-Style-KeepIcon-SL-4304.patch (1.4 KB) - added by manuq 8 years ago.
Artwork patch.

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by humitos

Screenshot comparing both

comment:1 Changed 8 years ago by humitos

  • Owner changed from manuq to humitos
  • Status changed from new to accepted

Changed 8 years ago by humitos

Changed 8 years ago by humitos

Changed 8 years ago by humitos

comment:2 Changed 8 years ago by humitos

  • Cc manuq erikos added
  • Keywords r? added

Attached 3 patches. This can't be done just with .css because the dark gray background will be kept in ":active" state after we click on the icon and leave it with the mouse pointer.

  • sugar.patch:
    • Uses "button-press" and "button-release" to change the background properly
    • Changes the star colors on "enter-notify" and "leave-notify"
    • Sets the size of the widget
  • sugar-artwork: Adds SugarKeepIcon to the ".cell.sugar-icon-cell" properties so they share the behaviour.
  • sugar-toolkit-gtk3:
    • Adds a helper method called "get_gdk_rgba_color" to get a Gdk.RGBA color needed by "Widget.override_background_color"
    • Adds the background color needed by SugarKeepIcon

Changed 8 years ago by manuq

Shell patch based on humitos one.

Changed 8 years ago by manuq

Artwork patch.

comment:3 Changed 8 years ago by manuq

Attached a follow up of humitos patches:

  • use a custom CSS for the press state, so it can be styled in the theme, and there is no need for the toolkit patch
  • in the CSS, reuse the CanvasIcon rules
  • fix this issue on humitos patch:

with a non-starred entry,

  1. do a mouse enter - star gets user colors
  2. do a mouse leave - star gets white fill, but border is still on the user colors, should be grey

comment:4 Changed 8 years ago by erikos

  • Keywords r+ added; r? removed

Ok, patch looks good, please remove the debug log. I tested with the mouse, please test with touch as well.

It can be classified a regression, since the mouse usage of this button does not work anymore as before.

comment:5 Changed 8 years ago by manuq

  • Resolution set to fixed
  • Status changed from accepted to closed

Pushed shell dc027d62 and artwork 2b41125e .

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.