Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4303 closed defect (fixed)

Journal sort palette missing grey margin edge to palette

Reported by: garycmartin Owned by: manuq
Priority: Low Milestone:
Component: Sugar Version: 0.98.x
Severity: Minor Keywords: regression, theme, r+, olpc-test-pending
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Spotted a new case of missing palette grey margin edge theming on the Journal sort palette (not fixed by http://bugs.sugarlabs.org/attachment/ticket/3936/0001-Get-back-margin-of-toolbuttons-SL-3936.patch.

See attached screen shot for 12.2.0 vs 13.1.0 build 16 (with the aforementioned patch) palette differences.

Attachments (4)

Journal_sort_view_palette_theme.png (35.3 KB) - added by garycmartin 8 years ago.
0001-ColorToolButton-do-the-drawing-in-the-correct-order-.patch (1.8 KB) - added by manuq 8 years ago.
Fix for the ColorToolButton.
0001-ColorToolButton-ToggleToolButton-do-the-drawing-in-t.patch (3.0 KB) - added by manuq 8 years ago.
v2. Fix for the ColorToolButton and the ToggleToolButton (like the wrap lines button in Log activity).
0002-Journal-SortingButton-port-palette-to-custom-palette.patch (2.2 KB) - added by manuq 8 years ago.
Port palette of journal SortingButton makes the outline visible.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by garycmartin

comment:1 Changed 8 years ago by manuq

  • Priority changed from Unspecified by Maintainer to Low
  • Severity changed from Unspecified to Minor

comment:2 Changed 8 years ago by erikos

Looks like the 'word wrap' Palette in the Log activity has the same issue.

comment:3 Changed 8 years ago by manuq

Color toolbutton in Paint too.

Changed 8 years ago by manuq

Fix for the ColorToolButton.

comment:4 Changed 8 years ago by manuq

  • Keywords r? added

Changed 8 years ago by manuq

v2. Fix for the ColorToolButton and the ToggleToolButton (like the wrap lines button in Log activity).

comment:5 Changed 8 years ago by manuq

Fixing the ColorButton and the ToggleToolButton was an easy fix, just doing the same as ToolButton does.

Ironically, I couldn't solve the sort button in the Journal, which inherits ToolButton and doesn't override the do_draw. But as this is low priority, I'm moving to more interesting bugs for now.

Changed 8 years ago by manuq

Port palette of journal SortingButton makes the outline visible.

comment:6 Changed 8 years ago by manuq

The ColorButton and ToggleToolButton fix was pushed to toolkit as 8a9d10cd . Attached is a shell patch for the Journal SortingButton.

comment:7 Changed 8 years ago by manuq

  • Keywords r+ olpc-test-pending added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

Pushed 6e2c593e .

comment:8 Changed 8 years ago by dnarvaez

  • Component changed from sugar-artwork to Sugar

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.