Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4296 closed defect (notsugar)

SugarExt volume control set volume to 0

Reported by: dsd Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

On OLPC XO-4 running OLPC 13.1.0 build 16, this command sets the volume to 0:

python -c "from gi.repository import SugarExt; SugarExt.VolumeAlsa().set_volume(80)"

(check by running "alsamixer" in another window and watching the effect on the PCM mixer)

Need to check which units are reported by alsmixer (I think its %) and which units are taken as input by VolumeAlsa. Setting the volume to 98 via sugarext results in it being set as 49 in alsamixer.

Change History (2)

comment:1 Changed 8 years ago by dsd

  • Resolution set to notsugar
  • Status changed from new to closed

In the end this was a kernel bug.

SugarExt sets its values on a linear scale, and alsamixer reads them on a logarithmic scale (dB). And because the kernel had almost 1000dBs of range (oops), setting 80% on a linear scale was actually to 0 on the logarithmic scale. The problem could even be seen in amixer vs alsamixer (taking sugar out of the equation).

Having shuffled mixers around in the latest XO-4 kernel, things are now working.

comment:2 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.