Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4288 closed defect (fixed)

Measure has very low gain and broken gain control on second and subsequent runs after reboot

Reported by: carrott Owned by: walter
Priority: Unspecified by Maintainer Milestone:
Component: Measure Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

On the first run of Measure 42 after a reboot on 13.1.0 build 15 on XO-1.75 the microphone input gain is very reasonable. The gain control works as expected. After stopping and restarting, the gain control does not work and the input gain is very very small. Rebooting restores the good behavior.

This is not a problem with Measure 37.1 on 12.1.0 on XO-1.75. Updating that 12.1.0 laptop to Measure 42 yields the same behavior as on 13.1.0 so this would appear to be a Measure bug.

Change History (8)

comment:1 Changed 8 years ago by walter

As a control, I ran Measure 42 on 13.1 on an XO 1.5 (which has more stable audio drivers) and it behaves fine.

Need to reflash my 1.75, which is still on 13.1-os7, but on os7 I can reproduce the problem as described in the ticket. Investigating.

comment:2 Changed 8 years ago by walter

Seems to be related to mic boost. Reseting in alsamixer between runs resolves the problem.

comment:3 Changed 8 years ago by dsd

  • Milestone changed from Unspecified by Release Team to 0.98

comment:4 Changed 8 years ago by walter

A bit closer to understanding what is going it. The difference between v37 and v42 on 1.75 is the presence of the MIC1 Boost controller. Prior to v42, mic boost was not being set on 1.75. So analog audio worked since it was never turned off. (It also explains some inconsistencies in DC mode calibration.) However, with the controller added in v42, MIC1 Boost can be turned off, but not turned back on. Further investigation needed into that problem.

comment:5 Changed 8 years ago by walter

http://git.sugarlabs.org/measure/mainline/commit/d36a2809a6574d62ef4f52e860754e139f3c1c02

Tested on XO 1.75 running 13.1 (OS 15) and XO 1.5 running 13.1 (OS 15)

comment:6 Changed 8 years ago by walter

Measure 44 has this patch incorporated. Problem should be fixed.

comment:7 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

fixed in v44

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.