Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4278 closed defect (obsolete)

XO-hangs on XO-1.75-touch

Reported by: ajay_garg Owned by:
Priority: High Milestone:
Component: untriaged Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: godiard, pgf Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Testing http://build.laptop.org/13.1.0/os14/xo-1.75/31014o2.zd on a XO-1.75 touch, I note the following ::

a)
After the image is flashed, the XO works fine in general; more importantly, as long as all the work is being done via touchpad-pointer (and not through finger-touches), things work perfect.

b)
Working through finger-touches also work well, as long as c) does not happen.

c)
At some RANDOM point in time, doing "Finger-touch on Home-View XO-icon" ==> "Finger-touch on My-Settings" causes the settings-window to NOT open.

Thereafter, all "clicks" (via finger-touch, and touchpad-window) stop working.

Also, attaching the logs, when this scenario appears.

Attachments (3)

hang_messages (50.1 KB) - added by ajay_garg 8 years ago.
hang_dmesg (40.4 KB) - added by ajay_garg 8 years ago.
hang_shell_log (652 bytes) - added by ajay_garg 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by ajay_garg

Changed 8 years ago by ajay_garg

Changed 8 years ago by ajay_garg

comment:1 Changed 8 years ago by godiard

This mesage appear in sugar.log when this error happen:

(sugar-session:556): Gtk-CRITICAL : _gtk_widget_captured_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

comment:2 Changed 8 years ago by godiard

More information:

The touchpad is working, because the mouse cursor is moved, and the gesture with touch to show/hide the frame is recognized, but click or touch is not recognized, and when one of these event is triggered, the error

(sugar-session:556): Gtk-CRITICAL : _gtk_widget_captured_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

appear in shell.log

(in this case 556 is sugar-session pid, no the line in the code)

Testing with os15 and all the last gtk, pygobject rpms from erikos

comment:3 Changed 8 years ago by godiard

  • Priority changed from Unspecified by Maintainer to High

comment:4 Changed 8 years ago by erikos

Can you paste the full shell.log? And of course if there are some (even if minimal) hints how it could be reproduced would be appreciated.

One reference for the error message: http://www.mail-archive.com/gtk-app-devel-list@gnome.org/msg08582.html

comment:5 Changed 8 years ago by godiard

  • Resolution set to obsolete
  • Status changed from new to closed

Ajay, if you can retest with a new image, and the problem continues, please reopen.

comment:6 Changed 7 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.