Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4265 closed defect (fixed)

Write does react strange to mouse movement

Reported by: erikos Owned by: godiard
Priority: Immediate Milestone:
Component: Write Version: 0.97.x
Severity: Blocker Keywords: regression
Cc: garnacho, dsd Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

os15, Write 83

  • open Write
  • type in some text
  • go with the mouse to the text options to make the text bigger

---> there are some strange selections

Change History (6)

comment:1 Changed 8 years ago by erikos

  • Keywords regression added

I just tested on 12.1.0 with Write 79 and came up with this test case that I passed successfully on the 12.1.0 build.

http://wiki.sugarlabs.org/go/Features/Touch/Testing#Write_an_essay_about_turtles_in_the_Write_activity

comment:2 Changed 8 years ago by erikos

Works on the 1.5. The regression has been seen on the 1.75 and the XO-4.

comment:3 Changed 8 years ago by godiard

  • Cc garnacho dsd added

I think it's not only a Write thing. When the mouse is in this "drag mode" (usually after using the touch a lot, if you go to the Sugar Home, moving the cursor over any activity icon in the home, stick the icon to the mouse cursor.

We saw this before. I don't know if this is related to gtk or x changes.

comment:4 Changed 8 years ago by erikos

Sounds like related indeed: http://bugs.sugarlabs.org/ticket/4132#comment:7

The strange thing is, I have seen it on an XO-1.5 as well (if I was not completely wrong yesterday) and there we do not have the custom xorg-x11-server. We have to keep an eye on it.

comment:5 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Tested in os16, with the rpms from [1] and the problem is not present anymore.

Tried using touch and mouse selections, and scrolling.

[1] http://dev.laptop.org/~gonzalo/olpc10/

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.