Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4256 closed defect (fixed)

Browse i18n improvement requested

Reported by: cjl Owned by: manuq
Priority: Low Milestone:
Component: Browse Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

potupdater is now throwing this warning:

downloadmanager.py:120: warning: 'msgid' format string with unnamed arguments cannot be properly localized:

The translator cannot reorder the arguments.
Please consider using a format string with named arguments,
and a mapping instead of a tuple for the arguments.

Please re-write the variable substitution in the following UI string so that it can be localized unambiguously.

downloadmanager.py:120
Download "%s" requires %.2f MB of free space, only %.2f MB is available

Change History (8)

comment:1 Changed 10 years ago by manuq

  • Milestone changed from Unspecified by Release Team to 1.0

Setting it to 1.0 milestone so we can fix it early next cycle.

comment:2 Changed 10 years ago by lionaneesh

  • Bug Status changed from Unconfirmed to Assigned
  • Priority changed from Unspecified by Maintainer to Low
  • Severity changed from Unspecified to Minor

comment:3 Changed 10 years ago by cjl

Please act on the fix/merge request above. Activities are coming from frozen repo for the 13.1 build now, so it will not impact DSD (although the activity would be better with the fix).

comment:4 Changed 10 years ago by cjl

Please land the fix as soon as possible.

comment:5 follow-up: Changed 10 years ago by cjl

I have seen changes landing in Browse since this was requested. Is there a valid reason for further delay in landing this simple but important fix?

comment:6 in reply to: ↑ 5 Changed 10 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Replying to cjl:

I have seen changes landing in Browse since this was requested. Is there a valid reason for further delay in landing this simple but important fix?

OK is done now. No particular reasons for delaying, other than my own slowness. Thanks lionaneesh and cjl.

Pushed as b46d3767 and 2811869e .

comment:7 Changed 10 years ago by cjl

Thank you for addressing this request. BTW, this fix brought to you by our GCI participation.

comment:8 Changed 9 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.