Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4254 closed defect (fixed)

Measure's FFT mode broken

Reported by: greenfeld Owned by: walter
Priority: Normal Milestone:
Component: Measure Version: 0.97.x
Severity: Major Keywords: regression
Cc: godiard, dsd Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Start Measure and verify you can see audio on the oscilloscope.
  2. Click on the Sine Wave in the top menu to switch to FFT (frequency graphing) mode. Nothing will be displayed.
  3. Clicking through various measurement modes eventually will restore the original Sine wave, but going back directly does not seem to be possible.

Seen in OLPC 13.1.0 os12/Measure-42 on XO-1.5 and XO-1.75

Change History (8)

comment:1 Changed 8 years ago by walter

The problem seems to be a change in the behavior of the numpy multiply function. Looking into it.

comment:2 Changed 8 years ago by walter

using astype seems to fix the problem... pushing a patch

http://git.sugarlabs.org/measure/mainline/commit/2a37418e83f48b0b9c8340a0ac8dfc19648eb85e

Will be included in next release

comment:3 Changed 8 years ago by greenfeld

  • Cc godiard added

This likely needs a release for 13.1.0.

comment:4 Changed 8 years ago by dsd

  • Priority changed from Unspecified by Maintainer to Normal

Yes, Walter please make sure a release is made within the next 2 weeks. Sooner is better.

comment:5 Changed 8 years ago by walter

Patch is included in v44.

comment:6 Changed 8 years ago by godiard

  • Cc dsd added

Dsd, We need this version included to fix the regression

comment:7 Changed 8 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

That is being tracked in http://dev.laptop.org/ticket/12398 so I'll close this ticket. Thanks.

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.