Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4226 closed defect (duplicate)

Shell traceback logged as a new buddy appears in the neighbourhood

Reported by: garycmartin Owned by: manuq
Priority: Normal Milestone:
Component: Sugar Version: 0.97.x
Severity: Minor Keywords: 13.1.0, regression
Cc: goadiard, ajay_garg Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

13.1.0, build 11:

While watching the shell logs of one XO and booting a second, a shell traceback is logged at about the same point that the buddy appears in the neighbourhood zoom view. The test was repeated several times, all with the same traceback.

1352813699.069008 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 430, in __buddy_info_updated_cb
    self.emit('buddy-updated', self._buddy_handles[handle], properties)
KeyError: dbus.UInt32(3L)

Change History (8)

comment:1 Changed 8 years ago by garycmartin

On the booting laptop

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in __active_activity_changed_cb
    connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]
TypeError: 'NoneType' object has no attribute '__getitem__'

And also:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 430, in __buddy_info_updated_cb
    self.emit('buddy-updated', self._buddy_handles[handle], properties)
KeyError: dbus.UInt32(3L)

comment:2 Changed 8 years ago by manuq

  • Owner changed from erikos to manuq
  • Status changed from new to assigned

Yes I have seen this in the logs too.

comment:3 Changed 8 years ago by manuq

  • Keywords regression added; triage removed

This is a regression since 13.1.0 . Tagging it for the regressions-only bugfixing.

comment:4 Changed 8 years ago by erikos

  • Milestone changed from 0.84 to 0.98
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor

comment:6 Changed 8 years ago by ajay_garg

  • Cc ajay_garg added

comment:7 Changed 8 years ago by manuq

  • Resolution set to duplicate
  • Status changed from assigned to closed

Dup of #3169

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.