Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4225 closed defect (notabug)

OSK Shift and Enter keys

Reported by: humitos Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I've just realize that if you press SHIFT and the Enter on a input field (I tested this in Browse) and then press SHIFT again the letters don't go to lowercase. You have to press SHIFT one more time.

Test case:

  1. Go to eBook mode
  2. Open Browse
  3. Tap on the Google search input
  4. Tap on SHIFT
  5. Letters go uppercase
  6. Tap on ENTER
  7. A google search is performed, and Google Home Page is loaded
  8. Letters are still in uppercase
  9. Tap on SHIFT again

Issue:

Nothing happens

Expected behaviour:

Letters should go to lowercase

Environment:

XO-4 13.1.0 os11

Change History (3)

comment:1 Changed 8 years ago by manuq

  • Resolution set to notabug
  • Status changed from new to closed

Not a bug. This is because pressing Shift twice you stick to uppercase letters. This is good to type a sentence all uppercase. But we don't have the visual feedback in the OSK at the moment.

comment:2 Changed 8 years ago by manuq

  • Keywords triage removed

comment:3 Changed 8 years ago by manuq

OSK visual feedback for Shift states tracked in: http://dev.laptop.org/ticket/12308

Note: See TracTickets for help on using tickets.