Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4220 closed defect (fixed)

Handle issues in Write

Reported by: erikos Owned by: godiard
Priority: High Milestone:
Component: Write Version: Unspecified
Severity: Unspecified Keywords:
Cc: garnacho Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Build: os11

  • insert cursor does not update position
  • insert handle is right handle
  • there are no left/right handles shown for a selection

Change History (11)

comment:1 in reply to: ↑ description Changed 8 years ago by garycmartin

Replying to erikos:

Build: os11

  • insert cursor does not update position

The insertion handle should either update position to match any cursor movement, or perhaps more easily, just disappear when the user starts typing/navigating with a keyboard/OSK/Screen-bezel-game-keys.

  • insert handle is right handle

Insert handle is 'cursor-handle-bottom', confirmed this is just an issue in Write, the rest of build 11 seems to use the correct insertion handle.

  • there are no left/right handles shown for a selection

If you switch away to a different view, and back again, the handles are correctly drawn, but any user interaction with the canvas will loose them again.

Also noticed that:

  • Write still has self.abiword_canvas.set_word_selections set to true making tapping to deselect, or tapping to just place the cursor somewhere much more tricky (usually a selection is triggered)
  • Text selections can still be dragged via touch, making it very easy to rip-up and mess-up your document accidentally

comment:2 Changed 8 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98

comment:3 Changed 8 years ago by godiard

  • Keywords triage removed

comment:4 Changed 8 years ago by godiard

  • Priority changed from Unspecified by Maintainer to High

comment:5 follow-up: Changed 8 years ago by garycmartin

Testing in Build 12, Write-83:

  • insert cursor does not update position when typing
  • insert handle is still showing as the right/bottom handle, it should be cursor-handle-insert
  • FIXED: left and right selection handles are now drawing when you make a selection, note however that dragging either one of them leaves a trail of un erased handles until you pause the dragging movement.

comment:6 in reply to: ↑ 5 Changed 8 years ago by garnacho

Replying to garycmartin:

Testing in Build 12, Write-83:

  • insert cursor does not update position when typing
  • insert handle is still showing as the right/bottom handle, it should be cursor-handle-insert

It seems to me like the patch in http://bugzilla.abisource.com/show_bug.cgi?id=13410#c5 isn't included yet, that patch contains all latest fixes done in this regard, and also updated the insertion cursor style details to match with what has been committed in gtk+ master (the style class used changed slightly, insert-cursor vs insertion-cursor)

From what I see sugar-artwork did update, so the previously used class name isn't matched anymore in the theme, hence falling back to the selection-end handle

comment:7 Changed 8 years ago by godiard

This is my fault olpc5 rpm was not included because I uploaded it to the wrong directory.

I have created the repo http://git.sugarlabs.org/olpc-abiword-rpm to have a control of the changes included in every rpm version.


comment:8 Changed 8 years ago by godiard

olpc6 abiword rpms uploaded to public_rpms directory with the latest patches from garnacho

comment:9 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 8 years ago by godiard

Is working ok in os36

comment:11 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.