Opened 8 years ago

Closed 8 years ago

#4214 closed defect (notabug)

There is no way to start a new instance of an already opened book

Reported by: humitos Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Read Version: Unspecified
Severity: Unspecified Keywords: triage
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Download a book from internet:
    1. Go to Browse
    2. Search "peter gutenberg" in Google
    3. Download .epub version
  2. Open it from the Journal
  3. Make some bookmarks and move over the whole book
  4. Close Read
  1. Open a fresh instance of Read
  2. Open "Peter Pan" entry

Issue:

My bookmarks are already there

Expected behaviour:

Do not show the bookmarks. Start a new/fresh instance of Read with that book.

Environment:

XO-4 13.1.0 os11

Change History (3)

comment:1 Changed 8 years ago by humitos

Actually, I tried removing all the entries of "Peter Pan" from my Journal and downloading the book again. My bookmarks are still there! Oh!

comment:2 Changed 8 years ago by godiard

That's due to the way Read save the bookmarks.

Read have a database with the bookmarks, and the book is identified by the file hash.

Then, the bookmarks are not saved as metadata in the book, but in Read database. I do not see this as a bug, because do not hurt the user. A connected feature could be save the bookmarks as metadata in the journal, now we copy the metadata in pendrives too, then should be possible share bookmarks between users (But Read don't know how display bookmarks from different users right now, then we need analyze all together)

comment:3 Changed 8 years ago by humitos

  • Resolution set to notabug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.