Opened 8 years ago

Closed 8 years ago

#4212 closed defect (fixed)

In portrait orientation, toolbar does overflow and does leave some widgets in non usable ways

Reported by: garycmartin Owned by: manuq
Priority: High Milestone: Unspecified
Component: Browse Version: 0.97.x
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by erikos)

Browse case:

In portrait orientation toolbar URL widget is almost unusable due to small size, it is only large enough to show about 7 or 8 characters of text, and the search history is close to useless with items like "Re... htt..." and "OL... file:..."

13.1.0 build 11: XO-1.75

Change History (14)

comment:1 follow-up: Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned

Hmm, this one is difficult. Should we make the entry a minimum size so that more icons overflow in the portrait mode? The < > buttons I would not like to see overflowing. The favourite icon would maybe be ok or the home button, but that is already positioned at the left to the url entry.

Gary, suggestions please :)

comment:2 Changed 8 years ago by manuq

  • Milestone changed from Unspecified by Release Team to 1.0

This is worth fixing. But being realistic, not in this cycle. Moving out.

comment:3 in reply to: ↑ 1 ; follow-up: Changed 8 years ago by garycmartin

Replying to erikos:

Hmm, this one is difficult. Should we make the entry a minimum size so that more icons overflow in the portrait mode? The < > buttons I would not like to see overflowing. The favourite icon would maybe be ok or the home button, but that is already positioned at the left to the url entry.

Nice though, it would help a little, but not enough to really make a difference.

Gary, suggestions please :)

We should try and find a solution that helps the other activity cases as well. Suggestions so far range from having some Activities with custom portrait orientation toolbar layouts (trying to prioritise key features); or to changing the toolbar overflow behaviour so that the tools overflow in to a new secondary toolbar. This requires some design cycles, not something we have an obvious, quick, solution for right now.

comment:4 in reply to: ↑ 3 Changed 8 years ago by erikos

  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

Replying to garycmartin:

Replying to erikos:

Hmm, this one is difficult. Should we make the entry a minimum size so that more icons overflow in the portrait mode? The < > buttons I would not like to see overflowing. The favourite icon would maybe be ok or the home button, but that is already positioned at the left to the url entry.

Nice though, it would help a little, but not enough to really make a difference.

Gary, suggestions please :)

We should try and find a solution that helps the other activity cases as well. Suggestions so far range from having some Activities with custom portrait orientation toolbar layouts (trying to prioritise key features); or to changing the toolbar overflow behaviour so that the tools overflow in to a new secondary toolbar. This requires some design cycles, not something we have an obvious, quick, solution for right now.

Ahhh, the secondary toolbar was as well something that came to my mind directly. The 'other toolbar in portrait mode' sounds scary from an implementation point of view. If we would go down that road, the secondary toolbar could be a fallback for the activities not handling that themselves.

comment:5 Changed 8 years ago by erikos

  • Keywords triage removed

comment:6 Changed 8 years ago by erikos

  • Component changed from Browse to sugar-toolkit-gtk3
  • Description modified (diff)
  • Owner changed from manuq to erikos
  • Summary changed from In portrait orientation, toolbar URL widget is almost unusable due to small size to In portrait orientation, toolbar does overflow and does leave some widgets in non usable ways

comment:7 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:8 Changed 8 years ago by dnarvaez

  • Milestone changed from 1.0 to Unspecified

comment:9 Changed 8 years ago by dnarvaez

  • Bug Status changed from Assigned to Unconfirmed

comment:10 Changed 8 years ago by dnarvaez

  • Component changed from Sugar to Browse
  • Owner changed from erikos to manuq

comment:11 Changed 8 years ago by walter

I made a version for AU that works well. We should consider upstreaming it. We also should make some recommendations in the HIG for how to best handle these situations. Not difficult, but it takes some planning by the activity developer.

comment:12 Changed 8 years ago by manuq

I looked at the patch you sent me Walter, and today I did a slightly different approach.

http://dev.laptop.org/~manuq/browse-url-entry.png

I will make it work only in portrait mode, and will make the icons left align in that case, except for the Stop.

comment:13 Changed 8 years ago by walter

Making it work only in Portrait mode (or when the screen is too narrow for all the buttons) works for me :)

In my version, I put the nav forward/back buttons on the same palette as the entry. I think they are better there, but I won't press the point.

Thanks for fixing this.

comment:14 Changed 8 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in master branch, commit b5fff700 . And sugar-98 branch, commit bc272c54 .

Note: See TracTickets for help on using tickets.