Opened 7 years ago

Closed 4 years ago

#4205 closed defect (duplicate)

Icon below buddy on Home View shows a closed activity

Reported by: humitos Owned by: erikos
Priority: Low Milestone: Unspecified
Component: Sugar Version: 0.97.x
Severity: Minor Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I'm not sure how I arrived at this state but finally I get an icon of an activity that is already closed. See the screenshot attached.

Attachments (1)

Screenshot of _Home_.png (76.4 KB) - added by humitos 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by humitos

comment:1 follow-up: Changed 7 years ago by erikos

  • Priority changed from Unspecified by Maintainer to Low
  • Severity changed from Unspecified to Minor

Ok, the activity crashed, probably #4193. If I remember correctly there is one ticket already open about this. Might be hard to fix, actually. I think not too important.

comment:2 Changed 7 years ago by erikos

Btw, not a regression.

comment:3 in reply to: ↑ 1 Changed 7 years ago by humitos

  • Cc humitos added

Replying to erikos:

Ok, the activity crashed, probably #4193

Well, I've just arrived at the same state. I did:

  1. Go to eBook mode
  2. Rotate the screen
  3. Open Physics
  4. Tap on the "Arrow that points to down" at the right of the screen (many times)
  5. The palette is not shown (#4210)
  6. Open the XO
  7. Use the touchpad to click the "Arrow"
  8. Click on Stop button
  9. Physics closes without problem

Finally, I have the Physics icon below the buddy in the Home View.

comment:4 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Keywords triage removed
  • Milestone changed from Unspecified by Release Team to 0.98
  • Version changed from Unspecified to 0.97.x

low priority, put it in 0.98 milestone, if we reach 0.98 and it has not been fixed, we move it out as it is not a regression

comment:5 Changed 7 years ago by humitos

Physics is crashing with this in the log after clicking on Stop button.

(sugar-activity:3535): Gdk-ERROR **: The program 'sugar-activity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 249 error_code 9 request_code 130 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Terminated by signal 5, pid 3535 data (None, <open file '<fdopen>', mode 'w' at 0x172dcd8>, 'd3464676b6a62ae0c9116a54b8053f5ad6ccb17b')

Maybe this is the reason of this issue.

comment:6 Changed 6 years ago by dnarvaez

  • Bug Status changed from Assigned to New

comment:7 Changed 6 years ago by walter

I fixed the problem with Physics. It was a premature exit of pygame. Many other pygame activities will suffer a similar problem. Not sure how Sugar can deal with this but worth investigating.

comment:8 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.98 to Unspecified

comment:9 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:10 Changed 4 years ago by quozl

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4932, which has simpler reproducer, closing this one.

Note: See TracTickets for help on using tickets.