Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4203 closed defect (fixed)

Text selection handlers disappears on Gtk.Entry when "Backspace" is pressed

Reported by: humitos Owned by: garnacho
Priority: High Milestone:
Component: Sugar Version: Unspecified
Severity: Major Keywords:
Cc: erikos Distribution/OS: OLPC
Bug Status: Assigned

Description (last modified by erikos)

Steps to reproduce it:

  1. Go to eBook mode
  2. Go to Home/Neighborhood/Group view
  3. Tap on the "Search" entry
  4. Text selection input handler is shown
  5. Type something
  6. The handler does update it's position accordingly
  7. Press "Backspace"

Issue:

The input handler does disappear when backspace is tapped on the OSK for the first time. It should update it's position like it did when entering new characters.

Expected behaviour:

Keep showing those handlers

Environment:

XO-4 13.1.0 os11

Attachments (1)

0001-Ensure-the-insertion-handle-stays-on-fake-events-eg-.patch (2.0 KB) - added by garnacho 8 years ago.
GTK+ patch to fix the issue

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by humitos

  • Description modified (diff)

comment:2 Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Description modified (diff)
  • Distribution/OS changed from Unspecified to OLPC
  • Milestone changed from Unspecified by Release Team to 0.98
  • Owner changed from erikos to garnacho
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major
  • Status changed from new to assigned

comment:3 Changed 8 years ago by erikos

  • Keywords triage removed

Changed 8 years ago by garnacho

GTK+ patch to fix the issue

comment:4 Changed 8 years ago by garnacho

  • Cc erikos added

With the last attached patch, both textviews and entries keep the insertion cursor visible on OSK typing

comment:5 Changed 8 years ago by godiard

Can we close this ticket? I can't reproduce it in os36

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.