Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4201 closed defect (notabug)

Text gets underlined after tapping once

Reported by: erikos Owned by: godiard
Priority: Low Milestone:
Component: Read Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Build: os11

Steps to reproduce:

  • resume in Read
  • tap once to go to the next page
  • then scroll

---> text gets underlined

Change History (6)

comment:1 Changed 8 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98
  • Priority changed from Unspecified by Maintainer to Low

comment:2 Changed 8 years ago by godiard

  • Keywords triage removed

comment:3 Changed 8 years ago by humitos

  • Cc humitos added
  • Resolution set to notabug
  • Status changed from new to closed

The problem here is with this ebook file in particular because its .css file is not well formed.

I unzipped it and modified the .css to remove the text-decoration: underline entry and it worked properly.

This is what I did:

$ unzip 24571.epub.images
$ grep -r "text-decoration" .
./24571/0.css:    text-decoration: none;
./24571/0.css:    text-decoration: none;
./24571/0.css:    text-decoration: underline
./24571/0.css:    text-decoration: underline
./24571/pgepub.css:    text-decoration: none
$ vim 24571/0.css

I changed text-decoration: underline by text-decoration: none and I don't see the text underlined anymore.

This entry shouldn't affect to the whole text because it's inside a a:hover directive but the .css files are not well formed (e.g. they missed a lot of ";" at the end of each line and maybe other issues) and I guess webkit is being confused.

comment:4 Changed 8 years ago by humitos

  • Resolution notabug deleted
  • Status changed from closed to reopened

I did some other tests and I found an issue related to the mouse cursor when it's hidden. Maybe related to #4068

I tested the same eBook in Calibre (http://calibre-ebook.com/) and it doesn't underline the text. Even when you hover the text with the mouse. On the other hand, in Read if you don't use the touchscreen feature when you hover the text it's underlined.

Taking a look at the Calibre's code I found it makes a CSS flattering to remove some entries from the .css and change fonts, size, and so. That's is why the text is not underlined on Calibre.

comment:5 Changed 8 years ago by godiard

  • Resolution set to notabug
  • Status changed from reopened to closed

That epub file is malformed, is not a Read issue.

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.