Opened 8 years ago

Last modified 5 years ago

#4183 reopened defect

XO-4 Browse slows execution even in background

Reported by: tonyforster Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I think this OS is slow. I notice it in Browse waiting for webpages but I also get slow repainting of the screen when the frame is dismissed. In the Journal, dropdown menus are slow to appear, up to 9 seconds from placing the cursor on an entry, up to 3 seconds for an erase confirmation dialog to appear

May have been also present in OS9, I am not sure but fairly sure it wasn't in OS8

Change History (9)

comment:1 Changed 8 years ago by tonyforster

  • Component changed from untriaged to sugar
  • Milestone changed from Unspecified by Release Team to 0.98
  • Owner set to erikos

This problem continues in OS11

comment:2 Changed 8 years ago by tonyforster

  • Resolution set to fixed
  • Status changed from new to closed

later builds seem ok, closing

comment:3 Changed 8 years ago by tonyforster

  • Component changed from sugar to Browse
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from XO-4 OS10 seems slow to XO-4 Browse slows execution even in background

comment:4 Changed 8 years ago by tonyforster

Still on OS24. Maybe not a bug but this seems new behaviour. Browse seems to be consuming a lot of cpu time when in the background on some websites. When viewing the Journal the frame can take up to 2 seconds to respond to the cursor in the corner and another 2 seconds to animate.

In Browse, go to http://www.etradesupply.com/oem-samsung-galaxy-note-2-sgh-i317-lcd-screen-and-digitizer-assembly.html?gclid=CNqb07e7tbQCFYsdpQodNHgA2g

Go to the Journal, activate the frame by putting the cursor in the corner

comment:5 follow-up: Changed 8 years ago by tonyforster

It seems like its only the Journal that's affected, frame activation seems OK for the home screen and the logviewer

comment:6 in reply to: ↑ 5 Changed 8 years ago by manuq

Replying to tonyforster:

It seems like its only the Journal that's affected, frame activation seems OK for the home screen and the logviewer

Can you compare with and without Browse activity in the background? Frame activation is slower in the Journal but for other reasons, see: http://bugs.sugarlabs.org/ticket/3831#comment:3

comment:7 Changed 8 years ago by tonyforster

Tried it just now on OS29, before opening Browse, in Journal frame activation is fast, maybe 1/10 sec, frame dismissal is slower maybe 0.5 sec. Open Browse* in background, in Journal frame activation still fast, 1/10 sec but dismissal is now 1.5 sec

I think this is separate from #3831, because at its worst, and I do not have a reliable way of reproducing the worst behaviour, the drawing of menus etc is badly affected too

  • browse was running 2tabs, the etradesupply link in the comment above and weatherzone.com.au Melbourne Weather

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

comment:9 Changed 5 years ago by quozl

@tonyforster, does the slowness go away with this patch;
https://github.com/sugarlabs/browse-activity/pull/18

I'm worried that closing tabs doesn't stop the browser rendering and updating the page, and the symptoms you describe three years ago seem to match this.

Note: See TracTickets for help on using tickets.