Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#418 closed defect (fixed)

Resolve Gitorious blacklisting issues with OUOSL.

Reported by: kushal Owned by: bernie
Priority: Urgent Milestone: Unspecified
Component: git.sugarlabs.org Version: Unspecified
Severity: Major Keywords:
Cc: bernie Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I can not push/pull on/from git.sugarlabs.org for jukebox activity.
Error I am getting:

[kdas@d80 jukebox-activity]$ git push
ssh_exchange_identification: Connection closed by remote host
fatal: The remote end hung up unexpectedly

Change History (13)

comment:1 Changed 12 years ago by bernie

  • Owner changed from bernie to kushal
  • Status changed from new to assigned

What's in your .git/config?

Specifically, are you using the push url exactly as shown in the repository page?

comment:2 Changed 12 years ago by kushal

I never changed anything, I was using this same repo few days back also when I made the last changes.

My .git/config

[core]

repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true

[branch "master"]
[remote "origin"]

url = gitorious@…:jukebox/mainline.git
fetch = +refs/heads/*:refs/remotes/origin/*

[user]

name = Kushal Das
email = kushal@…

comment:3 Changed 12 years ago by tomeu

Maybe related as to why I cannot log into gitorious any more from sunjammer? It used to work and last week stopped working.

comment:4 Changed 12 years ago by kushal

Now for me it looks my offcie ip is somehow blacklisted as if I try to push/pull from my home I am getting a different error (I need help on that also :p )

[kdas@d80 jukebox-activity]$ git push
To gitorious@…:jukebox/mainline.git

! [rejected] master -> master (non-fast forward)

error: failed to push some refs to 'gitorious@…:jukebox/mainline.git'

[kdas@d80 jukebox-activity]$ git pull
You asked me to pull without telling me which branch you
want to merge with, and 'branch.master.merge' in
your configuration file does not tell me either. Please
name which branch you want to merge on the command line and
try again (e.g. 'git pull <repository> <refspec>').
See git-pull(1) for details on the refspec.

If you often merge with the same branch, you may want to
configure the following variables in your configuration
file:

branch.master.remote = <nickname>
branch.master.merge = <remote-ref>
remote.<nickname>.url = <url>
remote.<nickname>.fetch = <refspec>

See git-config(1) for details.

comment:5 follow-up: Changed 12 years ago by wadeb

Your work IP has probably been blacklisted. That's the most common cause of Gitorious authorization problems. It happens after a few failed login attempts for whatever reason. To get unblacklisted, you have to open a support ticket with UOUSL.

Regarding your home issues, try just checking out again to a new working dir.

git pull gitorious@…:jukebox/mainline.git jukebox

comment:6 in reply to: ↑ 5 Changed 12 years ago by tomeu

  • Cc bernie added

Replying to wadeb:

Your work IP has probably been blacklisted. That's the most common cause of Gitorious authorization problems. It happens after a few failed login attempts for whatever reason. To get unblacklisted, you have to open a support ticket with UOUSL.

Arrgh! Can we put a big banner warning about this in git.sugarlabs.org?

I bet activity authors are spending more time wondering why their gitorious account stopped working than coding (I have wasted several hours on this).

comment:7 Changed 12 years ago by wadeb

  • Owner changed from kushal to bernie
  • Priority changed from Normal to Urgent
  • Severity changed from Unspecified to Major
  • Summary changed from Can not push/pull on/from git.sugarlabs.org for jukebox activity to Resolve Gitorious blacklisting issues with OUOSL.

I'm updating the subject and reassigning to bernie.

For now, as Tomeu says, we should put a message on the Gitorious page. I also added an entry to the ActivityTeam FAQ but I'm not sure how much help that is. I'll add something to the ActivityTeam News as well.

comment:8 Changed 12 years ago by bernie

I have pinged the OSL admins about this.

comment:9 follow-up: Changed 12 years ago by bernie

I was told the VM will be moved within two days.

comment:10 in reply to: ↑ 9 Changed 12 years ago by bernie

Replying to bernie:

I was told the VM will be moved within two days.

The above comment belonged to a different bug.

The OSL admins are looking for a general solution:

I'd like to come up with a scalable solution that will work for other
projects as well. Ideally, we'd give you access to manage the folks who
get blocked so that you don't have to go through us. If people are
constantly getting blocked, then they are doing something very wrong
anyways and they should learn what they are doing so they don't repeat
the issue.

I'm not sure when we'll get to this but hopefully soon since we're
having a similar issue for other projects we host.

comment:11 Changed 12 years ago by wadeb

Did the VM get moved yet? I haven't heard specific reports of this problem recently but it would be great to know that it's resolved.

comment:12 Changed 12 years ago by nubae

I'm getting the blacklisting problem when trying to git push now. My ip was working fine before, but after deleting a project and recreating it, ssh gives me:
nubae@homeserve:/opt/sugar.git/mainline> ssh gitorious@…
ssh_exchange_identification: Connection closed by remote host

I have emailed ouosl. I deleted and recreated my ssh key several times to verify...

David Van Assche

comment:13 Changed 12 years ago by bernie

  • Resolution set to fixed
  • Status changed from assigned to closed

I just got back from the OSL admins:

Bernie,

Sorry for the long delay time on getting back to you. We have increased
DENY_THRESHOLD_INVALID from 5 to 10 and decreased AGE_RESET_INVALID from
10 days to 6 hours. If you theory about people using
<user>@git.sugarlabs.org is correct this should significantly reduce the
number of accidental blocks.

Let me know if you continue seeing these.

Thanks,
-Russell

Please, reopen this bug if you still have trouble. You can also bother them directly on #osuosl.

Note: See TracTickets for help on using tickets.