Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4135 closed defect (fixed)

Text handle position cursor appears briefly in corner before moving to text field

Reported by: erikos Owned by: garnacho
Priority: High Milestone:
Component: Sugar Version: 0.97.x
Severity: Major Keywords: gtk
Cc: Distribution/OS: OLPC
Bug Status: Assigned

Description

In 13.1.0 os7 on XO-4, the on-screen keyboard position cursor appears painted briefly in the top-left corner before moving to the text field currently in use. This happens when a field is selected by touch using a finger.

We should not paint/show the pointer on-screen before it is in the proper location.

Attachments (1)

0001-texthandles-Keep-state-internally-to-avoid-X-overhea.patch (8.2 KB) - added by garnacho 8 years ago.
Patch to fix the issue

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by erikos

  • Summary changed from On-screen Keyboard OSK position cursor appears briefly in corner before moving to text field to Text handle position cursor appears briefly in corner before moving to text field

Changed 8 years ago by garnacho

Patch to fix the issue

comment:2 Changed 8 years ago by garnacho

This change has also been folded in the last upstream abiword patch, http://bugzilla.abisource.com/show_bug.cgi?id=13410#c5

comment:3 Changed 8 years ago by erikos

Carlos, against which branch is this fix?

comment:4 Changed 8 years ago by garnacho

Originally on master, shouldn't have any conflicts on gtk-3.6

comment:5 Changed 8 years ago by erikos

Ok, the patch does work, had to rebase a few text handle patches (took them from the 3.6. branch). The non-Write part will be in the upcoming gtk3-3.6.1-2.fc18.olpc

comment:6 Changed 8 years ago by erikos

This landed in os11.

Testing there (xo4, xo1.75), when the handle occurs we do not see the flickering anymore. But when the handle goes away the left side (exactly half of the handle) does get whited out first. Is this related? Carlos, can you reproduce that on an non-XO?

comment:7 Changed 8 years ago by godiard

Can we close this ticket? I can't reproduce it in os36

comment:8 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:10 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.