Opened 10 years ago

Last modified 10 years ago

#4121 new defect

Sliderule touchscreen - missing text

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sliderule Version: Unspecified
Severity: Unspecified Keywords:
Cc: dsd, gonzalo Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

OS8 XO-4
clicking on the slider or cursor blanks the text, resuming the text is truncated, 2 screenshots attached

Attachments (2)

Screenshot of %22Sliderule Activity%22.png (3.2 KB) - added by tonyforster 10 years ago.
Screenshot of %22Sliderule Activity%222.png (3.2 KB) - added by tonyforster 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by tonyforster

Changed 10 years ago by tonyforster

comment:1 Changed 10 years ago by tonyforster

sorry, screenshots no good, another os8 problem?

comment:2 Changed 10 years ago by walter

Anything of interest in the log files? (I still don't have an OS8 environment up and running, but OSK is allegedly breaking things there: Paint, ... Maybe you could see if Portfolio OSK is working properly?)

comment:3 Changed 10 years ago by tonyforster

No nothing in sliderule log. It looks like you can enter edit mode but can not enter text or exit. A screenshot would explain it better. :(

A quick look at Portfolio and I was able to use the osk to enter text below the slides ok.

comment:4 Changed 10 years ago by walter

I finally got os8 running. Definitely problems... Not sure why the font scaling is broken. And not sure why setting background to transparency ends up with background black... will keep looking.

comment:5 Changed 10 years ago by walter

  • Cc dsd gonzalo added
  1. override_background_color is definitely broken on os8
  2. it appears that PangoCairo.font_map_get_default().set_resolution is also broken
Note: See TracTickets for help on using tickets.