Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4093 closed defect (fixed)

Write: export to PDF crash the activity

Reported by: godiard Owned by: godiard
Priority: High Milestone:
Component: Write Version: Unspecified
Severity: Critical Keywords: regression, olpc-test-passed
Cc: garnacho Distribution/OS: Unspecified
Bug Status: Assigned

Description

Is happening with abiword 2.9.3 in F17. Need be tested in F18.

Attachments (2)

bt_crash_save_as_pdf (9.8 KB) - added by godiard 8 years ago.
fix-pdf-export.diff (1.7 KB) - added by garnacho 8 years ago.
patch

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by godiard

  • Priority changed from Unspecified by Maintainer to High

comment:2 Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Severity changed from Unspecified to Critical

Is a crasher, so I mark it critical.

comment:3 Changed 8 years ago by godiard

  • Keywords regression added

Changed 8 years ago by godiard

comment:4 Changed 8 years ago by godiard

  • Cc garnacho added

Attached bt, cc garnacho because I think is related to changes we are introducing.
Relevant part:

#0 getFrameImpl (this=0x0) at ../../../../src/af/xap/xp/xap_Frame.h:123
#1 FV_UnixSelectionHandles::FV_UnixSelectionHandles (this=0xea2cc4, view=0xea2788,

selection=...) at fv_UnixSelectionHandles.cpp:53

#2 0xb3b3fed4 in FV_View::FV_View (this=0xea2788, pApp=0x2f62c8, pParentData=<optimized out>,

pLayout=0xea2598) at fv_View.cpp:304

#3 0xb3d6b2f4 in IE_Exp_Cairo::_writeDocument (this=0xe8da58) at ie_exp_PDF.cpp:122

Changed 8 years ago by garnacho

patch

comment:5 Changed 8 years ago by garnacho

apparently the pdf export creates an extra widgetless view, this patch should let handles cope with that

comment:6 Changed 8 years ago by godiard

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

New rpms with this fix are available http://dev.laptop.org/~gonzalo/olpc11/

comment:7 Changed 8 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Write does not crash exporting PDFs with 13.1.0 os20.

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.