Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4089 closed defect (fixed)

Theme tray icon correctly

Reported by: erikos Owned by: erikos
Priority: High Milestone:
Component: Sugar Version: 0.97.x
Severity: Major Keywords: regression
Cc: Distribution/OS: OLPC
Bug Status: Assigned

Description

Theme the tray icons correctly (e.g. the battery icon in the Frame). See the Wireless icon in the Frame, it has a prelight color and is styled correctly when the Palette pops up.

Attachments (2)

theme_tray_icon.patch (895 bytes) - added by erikos 8 years ago.
First patch based on the toolbutton code
0002-TrayIcon-get-the-black-background-and-outline-for-pa.patch (1.6 KB) - added by manuq 8 years ago.
Added message to Simon's patch.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by erikos

First patch based on the toolbutton code

comment:1 Changed 8 years ago by manuq

I was wanting to solve this using the CSS, but for some reason removing this rule makes Sugar run very slow:

SugarHTray * , SugarVTray * {
    background-color: @toolbar_grey;
}

So I think we are ok with this approach for now, which is the same we did for toolbutton.

comment:2 follow-up: Changed 8 years ago by manuq

Another thing affecting the TrayIcon: the size is wrong, seems because set_size_request is deprecated.

By the way, I wonder why we have TrayIcon at all. We could use ToolButton directly. Wireless network button does that and looks ok.

comment:3 in reply to: ↑ 2 Changed 8 years ago by manuq

Replying to manuq:

Another thing affecting the TrayIcon: the size is wrong, seems because set_size_request is deprecated.

This is false, sorry.

By the way, I wonder why we have TrayIcon at all. We could use ToolButton directly. Wireless network button does that and looks ok.

There are differencies.

comment:4 Changed 8 years ago by manuq

  • Keywords regression added

Changed 8 years ago by manuq

Added message to Simon's patch.

comment:5 Changed 8 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Pushed e49f6211 . The prelight / hover issue will be done in #4301 .

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.