Opened 7 years ago

Last modified 4 years ago

#4058 new defect

GtkPaned can't be adjusted in touchscreen

Reported by: danielfrancis Owned by: erikos
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.97.x
Severity: Minor Keywords: 13.1.0, theme, patch
Cc: garycmartin Distribution/OS: OLPC
Bug Status: Resolved

Description (last modified by danielfrancis)

The control which allows to adjust the content of a GtkPaned is too thin for the fingers.
Affected activities distributed in the XO-4 build where I can see, are Chart, Pippy and Log.
An activity non-distributed in that build (written by me) which is also affected is Graph Plotter.

Change History (17)

comment:1 follow-up: Changed 7 years ago by garycmartin

Yes, also the Log Activity. The new GTK3 theme re-designs (not the Sugar theme) did seem to improve a little on the widget hit area http://developer.gnome.org/gtk3/3.2/panes.png, but maybe we're over-riding that improvement.

comment:2 Changed 7 years ago by danielfrancis

  • Description modified (diff)

comment:3 in reply to: ↑ 1 Changed 7 years ago by danielfrancis

Replying to garycmartin:

Yes, also the Log Activity.

Added to the description, thanks.

comment:4 Changed 7 years ago by manuq

  • Keywords 13.1.0 added
  • Milestone changed from Unspecified by Release Team to 0.98

comment:5 Changed 7 years ago by manuq

comment:6 follow-up: Changed 7 years ago by danielfrancis

Looking at the Adwaita theme and some patches in the GNOME archive, I made a patch.
Before sending it, I tell: The light grey in the separator is as confusing as the old tabs. Do you agree if I also change the color of the paned separator in my patch to @toolbar_grey?

comment:7 in reply to: ↑ 6 Changed 7 years ago by manuq

Hey Dani, please provide the patch as-is so I can see. Adwaita theme has a dotted line [1] do we had something like that before? Do we want that?

http://developer.gnome.org/gtk3/stable/panes.png

comment:8 Changed 7 years ago by danielfrancis

Yep, we have the dotted line in front of our eyes, but it can't be seen. It's very small and the colour is very similar to the separator. Lemme finish my homework and then I do the end tests on Sugar and send the patch, I think I found how to change the colour for those points.

comment:9 Changed 7 years ago by danielfrancis

  • Bug Status changed from Unconfirmed to Resolved

Patched at http://lists.sugarlabs.org/archive/sugar-devel/2012-October/040444.html
I could not change the color for the dotted points, but now in black they are seen.

comment:10 follow-up: Changed 7 years ago by manuq

  • Keywords theme added

Excellent! To be honest I dislike the toolbar-like black background. We use it exclusively in the toolbar and in palettes. I propose changing the dots instead. They are in fact SVG images, one for vertical pane and one for horizontal pane. Gary, can you come with a good idea, or even provide them? This are the ones used by Adwaita for reference:

comment:12 in reply to: ↑ 10 Changed 7 years ago by danielfrancis

  • Cc garycmartin added

Replying to manuq:

Excellent!

Thanks.

To be honest I dislike the toolbar-like black background.

I agree with you, having to choice between the toolbar-like and the unthemed background, I preferred the first one, but of course you may have a better idea.

We use it exclusively in the toolbar and in palettes. I propose changing the dots instead. They are in fact SVG images, one for vertical pane and one for horizontal pane. Gary, can you come with a good idea, or even provide them?

(Adding Gary to the CC)
I'm impressed looking that GNOME have in their repository SVG code with all the Inkscape spam: 107 lines to draw six points. :P

comment:13 Changed 7 years ago by manuq

  • Milestone changed from 0.98 to 1.0

Moving to next cycle as the activities usage is not so hurt because of this, also this requires UI change and we are in freeze now.

comment:14 Changed 6 years ago by dnarvaez

  • Component changed from sugar-artwork to Sugar
  • Owner changed from manuq to erikos

comment:15 Changed 6 years ago by dnarvaez

  • Milestone changed from 1.0 to Unspecified

comment:16 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:17 Changed 4 years ago by godiard

  • Keywords patch added
Note: See TracTickets for help on using tickets.