Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4055 closed defect (fixed)

Read: text selection have fg & bg black

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r+, 13.1.0, olpc-test-passed
Cc: manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Evince have a custom css and set:

EvView:selected {

background-color: @theme_selected_bg_color;

}

We need the same definition in our theme.

Attachments (1)

0001-Add-theme-needed-by-Evince-viewer-text-selection-SL-.patch (892 bytes) - added by godiard 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by godiard

  • Cc manuq added
  • Keywords r? added

comment:2 Changed 10 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Great! We also need to style the EvView background. Otherwise the selected text looks all black if unfocused. Testcase: select some text, then go to the search entry. This makes the trick and also styles the Abiword document as per your other patch. I'm doing in the same patch because is nicer to have one css rule for both:

EvView {
    background-color: @panel_grey;
}

EvView:selected,
ApDocView:selected {
    background-color: @selection_grey;
}

Pushed: 4759fd5d .

comment:3 Changed 10 years ago by manuq

  • Keywords r+ 13.1.0 olpc-test-pending added; r? removed

comment:4 Changed 10 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Highlighted text has a gray background in Read for PDF and EPUB files in OLPC 13.1.0 os8.

comment:5 Changed 10 years ago by dnarvaez

  • Component changed from sugar-artwork to Sugar

comment:6 Changed 10 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.