Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4030 closed defect (notsugar)

ImageViewer: fast rendering can't rotate

Reported by: godiard Owned by: humitos
Priority: Unspecified by Maintainer Milestone:
Component: Imageviewer Version: Unspecified
Severity: Unspecified Keywords:
Cc: greenfeld, humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Using the fast scaling, when the user rotates the image, is displayed broken. We need rotate over the temporal surface, and later do the fast scaling.

Attachments (5)

sugar-13.1.0_build_5.png (22.1 KB) - added by humitos 9 years ago.
Script ran in Sugar 13.1.0 Build 5 - XO 1.75
desktop-f17.png (22.4 KB) - added by humitos 9 years ago.
Script ran in my Desktop (Fedora 17)
cairo_rotate_example.py (4.6 KB) - added by humitos 9 years ago.
Test script with differents results in different platforms
13.1.0 - os6 - xo-4.png (21.2 KB) - added by humitos 9 years ago.
Script ran in Sugar 13.1.0 Build 6 - XO-4
13.1.0 - os6 - xo-1.5.png (20.1 KB) - added by humitos 9 years ago.
Script ran in Sugar 13.1.0 Build 6 - XO-1.5

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by godiard

  • Owner changed from godiard to humitos
  • Status changed from new to assigned

Changed 9 years ago by humitos

Script ran in Sugar 13.1.0 Build 5 - XO 1.75

Changed 9 years ago by humitos

Script ran in my Desktop (Fedora 17)

Changed 9 years ago by humitos

Test script with differents results in different platforms

comment:2 Changed 9 years ago by humitos

That script was stolen from here:

Changed 9 years ago by humitos

Script ran in Sugar 13.1.0 Build 6 - XO-4

comment:3 Changed 9 years ago by humitos

I tested rotation in XO-1.75 and the error happens but it does not happen in XO-4.

comment:4 Changed 9 years ago by godiard

Please check in xo-1.5 too.

If we confirm is hardware dependent, fill tickets in dev.laptop.org and copy Jon

comment:5 Changed 9 years ago by godiard

  • Cc Cerlyn added

Cerlyn, can you run the script cairo_rotate_example.py in xo-1, xo-1.5, xo-1.75 and fill tickets for Jon when needed?

comment:6 Changed 9 years ago by greenfeld

  • Cc greenfeld added; Cerlyn removed

Changed 9 years ago by humitos

Script ran in Sugar 13.1.0 Build 6 - XO-1.5

comment:8 Changed 8 years ago by humitos

  • Cc humitos added
  • Resolution set to notsugar
  • Status changed from assigned to closed

I'm closing this ticket because it's specific for OLPC XO.

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.