Opened 9 years ago

Closed 7 years ago

#4029 closed defect (fixed)

Remove temporary fix: Previously non-upstreamed locales now available

Reported by: cjl Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

lines 48 to 52 of

http://git.sugarlabs.org/sugar/mainline/blobs/master/extensions/cpsection/language/model.py

#FIXME: This is a temporary workaround for locales that are essential to
# OLPC, but are not in Glibc yet.
locales.append(('Kreyol', 'Haiti', 'ht_HT.utf8'))
locales.append(('Dari', 'Afghanistan', 'fa_AF.utf8'))
locales.append(('Pashto', 'Afghanistan', 'ps_AF.utf8'))

The ht_HT locale has since been upstreamed:

http://sourceware.org/git/?p=glibc.git;a=blob;f=localedata/locales/ht_HT;h=8ec865d1ce051956821fff98320f9d13cc7720e6;hb=HEAD

the ps_AF locale has since been upstreamed:

http://sourceware.org/git/?p=glibc.git;a=blob;f=localedata/locales/ps_AF;h=7f686abbb55af519cc6f96c5c180d412fc042340;hb=HEAD

We need to maintain this for Dari (fa_AF) and we may want to add entries for Quechua (quz) and Aymara (isocode in question, currently aym, likely to change to ayc).

For now, we should probably just remove the ht_HT and ps_AF lines.

Change History (2)

comment:1 Changed 8 years ago by cjl

Locale for Aymara (ayc_PE) has been released in glibc
http://sourceware.org/bugzilla/show_bug.cgi?id=14828

Locale for Quechua (Cuzco-Collao) (quz_PE) has been submitted to glibc
http://sourceware.org/bugzilla/show_bug.cgi?id=15887

Assuming I can get quz_PE landed, it should appear in their next release (2.19?). When that has happened and we are using 2.19, we will want to unwind the "special case" handling of quz_PE in a manner similar to what is requested for this ticket

see also #3692
http://bugs.sugarlabs.org/ticket/3692

comment:2 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Already removed in 918606103b8aa6357a9a7cab826dfbcdc621f6a3

Note: See TracTickets for help on using tickets.