Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4022 closed defect (fixed)

Sugar crashes touching the screen with 5 fingers

Reported by: humitos Owned by: erikos
Priority: Normal Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: erikos, manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Start Sugar - it will show the Home View
  2. Touch the screen with 5 fingers, forming a circle and move them to the centre of the screen

Issue:

Sugar crashes and it is restarted

Expected behaviour:

Not to crash.

Environment:

13.1.0 - os5 - XO 1.75

Comment:

If I comment out GObject.idle_add(setup_gesturehandler_cb) on /usr/bin/sugar-session and I restart Sugar this does not happen anymore.

Change History (6)

comment:1 Changed 9 years ago by godiard

  • Milestone changed from 0.96 to 0.98

comment:2 Changed 9 years ago by humitos

Sometimes I get this on the shell.log

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py", line 458, in __leave_notify_event_cb
    if self.palette.is_up():
AttributeError: 'NoneType' object has no attribute 'is_up'

comment:3 Changed 9 years ago by cjl

I cannot reproduce this on an XO-4 B1 with 13.1.0 - os5

comment:4 Changed 9 years ago by greenfeld

XO-4 B1's only can track two fingers by default, so this is an issue which only affects touchscreens which can track more points (such as the XO-1.75 touchscreen prototypes, and possibly other computers).

comment:5 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Can't reproduce with os11. Please reopen if needed

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.