Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4020 closed defect (duplicate)

Terminal-41 starts incompletely, bug related to previous saved session

Reported by: garycmartin Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone:
Component: Terminal Version: Unspecified
Severity: Unspecified Keywords: 13.1.0
Cc: danielfrancis, aguz Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by garycmartin)

Terminal-41 starts fine from a new session, but fails when resumed with previous saved state. New activity state is not being saved.

Here's a trace back after a resume from a Terminal-40 saved state:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/sugar3/activity/activity.py", line 538, in __canvas_map_cb
    self.read_file(self._jobject.file_path)
  File "/home/olpc/Activities/Terminal.activity/terminal.py", line 401, in read_file
    self._create_tab(tab_state)
  File "/home/olpc/Activities/Terminal.activity/terminal.py", line 342, in _create_tab
    vt.feed(l + '\r\n')
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Item 0: Must be number or single byte string, not unicode

Change History (8)

comment:1 Changed 9 years ago by garycmartin

Both XO-4 and 1.75 build 5's report the same version of vte are being used:

rpm -qa | grep vte
evtest-1.30-2.fc18.armv7hl
vte3-0.34.0-1.fc18.armv7hl
vte-0.28.2-7.fc18.armv7hl

comment:2 Changed 9 years ago by garycmartin

Just re-tested Terminal-40, and it runs fine on the XO-4 hardware. Any chance you could make sure Terminal-41 source was pushed back up to the main get repository, only v40 is there just now, thanks --G

comment:3 Changed 9 years ago by garycmartin

  • Description modified (diff)
  • Summary changed from Terminal-41 starts incompletely on XO-4, but works on XO-1.75, 13.1.0 build 5 to Terminal-41 starts incompletely, bug related to previous saved session

OK looks like a bug with resume saved state, and state saving, nothing to do with XO-4 hardware.

comment:4 Changed 9 years ago by danielfrancis

  • Cc danielfrancis added

comment:5 Changed 9 years ago by aguz

  • Cc aguz added

comment:6 Changed 8 years ago by godiard

Is a duplicate of #4131

comment:7 Changed 8 years ago by godiard

  • Resolution set to duplicate
  • Status changed from new to closed

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.