Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4019 closed defect (fixed)

Subtoolbars have 1px border

Reported by: manuq Owned by: manuq
Priority: Normal Milestone:
Component: Sugar Version: 0.97.x
Severity: Unspecified Keywords: r+
Cc: erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Attachments (3)

subtoolbar-height.gif (33.5 KB) - added by manuq 10 years ago.
subtoolbar-height2.gif (33.4 KB) - added by manuq 10 years ago.
0001-Fix-subtoolbars-height-SL-4019.patch (1.7 KB) - added by manuq 10 years ago.
Proposed fix.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by manuq

I have tried this change:

--- a/src/sugar3/graphics/toolbarbox.py
+++ b/src/sugar3/graphics/toolbarbox.py
@@ -286,8 +286,7 @@ class _Box(Gtk.EventBox):
 
 
 def _setup_page(page_widget, color, hpad):
-    vpad = style.FOCUS_LINE_WIDTH
-    page_widget.get_child().set_padding(vpad, vpad, hpad, hpad)
+    page_widget.get_child().set_padding(0, 0, hpad, hpad)
 
     page = _get_embedded_page(page_widget)
     page.modify_bg(Gtk.StateType.NORMAL, color)

And the subtoolbar gets the original height, but looses part of the top outline. See attached animation. Commit 820efa56 shows that this 'vpad' was in GTK2 too, so the issue is in another part.

Changed 10 years ago by manuq

Changed 10 years ago by manuq

Changed 10 years ago by manuq

Proposed fix.

comment:2 Changed 10 years ago by manuq

  • Cc erikos added
  • Keywords r? added

Changing the order of the drawing calls in the container widget fixes the outline drawing issue. Attached is a proposed patch and a new animation that shows it's working now.

comment:3 Changed 10 years ago by manuq

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

Pushed d3252365 and backported to 0.98 too.

comment:4 Changed 9 years ago by dnarvaez

  • Component changed from sugar-artwork to Sugar

comment:5 Changed 9 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.