Opened 7 years ago

Closed 4 years ago

#4000 closed defect (fixed)

Views: when Palette is up you can not switch views

Reported by: erikos Owned by: erikos
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.97.x
Severity: Critical Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  • go to Neighborhood View
  • click/tap on an icon

---> the Palette comes up

  • use the View keys on the keyboard to switch to the Home View

---> Palette which is up prevents this

(in os5)

Change History (9)

comment:1 follow-up: Changed 7 years ago by erikos

This is because the Palettes in the Views are a GTK.Menu which do grab focus when they are up.

There is an effort to do a grab override "to allow clients to intercept key or button events even if there is an existing device grab". But this won't land in time.

I will try to use our custom Palette in the Views and see how that goes. #4038 is effected by this as well, #4001 also.

comment:2 in reply to: ↑ 1 Changed 7 years ago by erikos

Replying to erikos:

This is because the Palettes in the Views are a GTK.Menu which do grab focus when they are up.

There is an effort to do a grab override "to allow clients to intercept key or button events even if there is an existing device grab". But this won't land in time.

I will try to use our custom Palette in the Views and see how that goes. #4038 is effected by this as well, #4001 also.

s/#4038/#3992

comment:3 Changed 6 years ago by dnarvaez

  • Bug Status changed from Assigned to New

comment:4 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.98 to Unspecified

comment:5 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:6 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:7 Changed 5 years ago by manuq

See #4768

comment:8 Changed 4 years ago by quozl

Is fixed now, tested in 0.107.2.

comment:9 Changed 4 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.