Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3998 closed defect (fixed)

Opening the control panel should not auto focus on its search area unless characters are typed

Reported by: garycmartin Owned by: manuq
Priority: Normal Milestone:
Component: Sugar Version: 0.97.x
Severity: Major Keywords: 13.1.0, r+, olpc-test-passed
Cc: manuq, cjl Distribution/OS: OLPC
Bug Status: Assigned

Description

To prevent the OSK from opening unnecessarily, the control panel should not auto focus on its search area, unless characters are typed, much like we now do for the home zoom views and the Journal search areas.

Attachments (2)

cp_unfocus_search.patch (1.7 KB) - added by erikos 9 years ago.
CP: Unfocus search, focus on startingto type
0001-Control-Panel-defocus-the-search-entry-by-default-SL.patch (2.5 KB) - added by manuq 8 years ago.
Candidate patch.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by garycmartin

In ebook mode, the CP (My Settings) is still partly obscured by the OSK as the search field is focused by default. As text search in the CP is a _very_ rare function, perhaps the low cost option is to not auto focus on the CP search area?

Changed 9 years ago by erikos

CP: Unfocus search, focus on startingto type

comment:2 follow-ups: Changed 9 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Cc manuq cjl added
  • Distribution/OS changed from Unspecified to OLPC
  • Keywords r? added
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Major

Above patch introduces a string addition ('Control Panel'), question for Chris if this ok.

@manuq: there is an issue in the patch, only one character is used at a time, maybe you can check that.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 9 years ago by garycmartin

Replying to erikos:

Above patch introduces a string addition ('Control Panel'), question for Chris if this ok.

@manuq: there is an issue in the patch, only one character is used at a time, maybe you can check that.

Thanks :) Just tested the patch:

  • the OSK is only very intermittently raising when the touching search field to focus it for entering a query. After much screen tapping it appears to only trigger if you first tap outside of the CP dialogue box, on the background parent view, and then back on the CP search field to get the OSK to trigger. This is also the same for any text widgets inside the various CP modules e.g. the About Me name input widget, the Date & Time search widget, or the Network server name widget.
  • focusing the search field usually results in text selecting some part of the grey 'Search in Control Panel' hint text
  • Suggest the hint string should be 'Search in Settings' so that we use the same language as else where in the user facing strings (CP is only the implementation name now)

comment:4 in reply to: ↑ 2 Changed 9 years ago by cjl

Replying to erikos:

Above patch introduces a string addition ('Control Panel'), question for Chris if this ok.

With a milestone of 0.98, this would not be under any "string freeze" of any sort, so why not?

If you want to backport, we have this string

../src/jarabe/controlpanel/cmd.py:31
sugar-control-panel: %s

A version that just dropped the %s would be easy to copy/modify from existing entries, I could handle it myself for any language.

comment:5 in reply to: ↑ 3 Changed 9 years ago by erikos

Replying to garycmartin:

Replying to erikos:

Above patch introduces a string addition ('Control Panel'), question for Chris if this ok.

@manuq: there is an issue in the patch, only one character is used at a time, maybe you can check that.

Thanks :) Just tested the patch:

  • the OSK is only very intermittently raising when the touching search field to focus it for entering a query. After much screen tapping it appears to only trigger if you first tap outside of the CP dialogue box, on the background parent view, and then back on the CP search field to get the OSK to trigger. This is also the same for any text widgets inside the various CP modules e.g. the About Me name input widget, the Date & Time search widget, or the Network server name widget.
  • focusing the search field usually results in text selecting some part of the grey 'Search in Control Panel' hint text
  • Suggest the hint string should be 'Search in Settings' so that we use the same language as else where in the user facing strings (CP is only the implementation name now)

Agreed with the name, the issue is the focusing problem, I have no idea yet what is causing it. Already lost too much time on it. If someone has an idea...

comment:6 Changed 9 years ago by erikos

I would add the place holder string now, so we do not have the issue with breaking the freeze (has no visual impact).

diff --git a/src/jarabe/controlpanel/toolbar.py b/src/jarabe/controlpanel/toolbar.py
index 2094d3b..1423e94 100644
--- a/src/jarabe/controlpanel/toolbar.py
+++ b/src/jarabe/controlpanel/toolbar.py
@@ -53,6 +53,8 @@ class MainToolbar(Gtk.Toolbar):
                                               'system-search')
         self._search_entry.add_clear_button()
         self._search_entry.set_width_chars(25)
+        text = _('Search in %s') % _('Settings')
+        self._search_entry.set_placeholder_text(text)
         self._search_entry.connect('changed', self.__search_entry_changed_cb)
         tool_item.add(self._search_entry)
         self._search_entry.show()

comment:8 Changed 8 years ago by manuq

  • Owner changed from erikos to manuq
  • Status changed from new to assigned

Changed 8 years ago by manuq

Candidate patch.

comment:9 Changed 8 years ago by manuq

Updated candidate patch with Simon suggestion, clear the search when a section is closed.

comment:10 Changed 8 years ago by manuq

  • Keywords r+ olpc-test-pending added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed ff734de4 .

comment:11 Changed 8 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Fixed in OLPC 13.1.0 os8.

comment:12 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.