Opened 9 years ago

Closed 7 years ago

#3994 closed defect (obsolete)

Physics crashes when the Triangle tool is used near the frame edge related to new Frame touch gesture

Reported by: garycmartin Owned by: erikos
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.97.x
Severity: Blocker Keywords: 13.1.0, regression
Cc: garnacho, erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Testing Physics with the new Frame touch gesture causes Physics to crash when the Triangle tool is used near the frame edge. Likely a bug in this particular tool getting caught out by the sudden event stream on touch release (all frame edge events seem to be being buffered until touch release). Physics crash was confirmed by Simon and checked that it does not occur when the gesture is disabled.

Change History (15)

comment:1 Changed 9 years ago by garycmartin

  • Component changed from untriaged to Physics
  • Owner set to garycmartin

comment:2 Changed 9 years ago by erikos

  • Bug Status changed from New to Assigned
  • Component changed from Physics to sugar-toolkit-gtk3
  • Owner changed from garycmartin to erikos
  • Severity changed from Unspecified to Blocker

Another good test case is Paint: In the Frame area start drawing slowly to not trigger a swipe. You just get a dot where you started the gesture. The Frame is not revealed and the drawing is not fully fulfilled neither.

(seen in os5)

comment:3 Changed 9 years ago by erikos

Ok, I was just verifying if the overlapping controller (hide/show) are causing the issue and removed the 4 for hiding but the issue still remains. (Tested with Paint).

comment:4 Changed 9 years ago by erikos

Another test, Browse: I zoomed into a page to have horizontal scrolling. When I start scrolling in one of the Frame areas it starts to scroll the moment I release my finger.

comment:5 Changed 9 years ago by godiard

Another issue probably related is described in #4024.

A ScrolledWindow inside a Notebook crash the activity. Removing the Notebook does not crash.

comment:6 follow-up: Changed 8 years ago by manuq

Our frame touch gesture changed to be raised from the top, not from all four sides. I suggest we close this as obsolete.

comment:7 in reply to: ↑ 6 Changed 8 years ago by garycmartin

Replying to manuq:

Our frame touch gesture changed to be raised from the top, not from all four sides. I suggest we close this as obsolete.

I was hoping to fix this as the gesture appears to expose a bug in that tool that the other tools didn't have, and adding gestures at some point may just trigger this issue again in the future.

comment:8 Changed 8 years ago by godiard

  • Keywords regression added

comment:9 Changed 8 years ago by manuq

  • Milestone changed from 0.98 to 1.0

Moving out to next cycle.

comment:10 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:11 Changed 8 years ago by dnarvaez

  • Milestone changed from 1.0 to Unspecified

comment:12 Changed 8 years ago by dnarvaez

  • Bug Status changed from Assigned to Unconfirmed

comment:13 Changed 7 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:14 Changed 7 years ago by walter

I cannot reproduce this with Sugar 100 and Physics 19.

comment:15 Changed 7 years ago by walter

  • Resolution set to obsolete
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.