Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3937 closed defect (fixed)

Paint canvas drawing lags behind tools in OLPC 13.1.0 os2

Reported by: greenfeld Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Paint Version: 0.97.x
Severity: Unspecified Keywords: olpc-test-passed
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Using the drawing tool, hold the primary mouse button down and rapidly move the pointer around.
  2. The canvas drawing that appears onscreen will lag behind the tool's movement, sometimes by several seconds.
  3. Other tools (Erase, etc.) seem to be similarly affected.

Seen on XO-1 & XO-1.75 with 13.1.0 os2/Paint-44. May be related to #3935.

Change History (7)

comment:1 Changed 7 years ago by godiard

#3935 is a TamTam ticket. Why you think is connected?

I think drawing is slower due to the use of cairo. We need see what can we do to improve performance from Paint side, but also look at cairo performance in general.

comment:2 Changed 7 years ago by greenfeld

#3935 is another problem which could be caused by slow drawing (by the activity or a toolkit, not the user) or failure to properly tell some layer (GTK, the video card, etc.) when to flush output to show it onscreen.

comment:3 Changed 7 years ago by dsd

  • Milestone changed from Unspecified by Release Team to 0.98

comment:4 Changed 7 years ago by godiard

  • Keywords olpc-test-pending added

Please test again in os5

comment:5 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Is working better now, reopen if needed.

comment:6 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Drawing seems to be a bit better on slower XOs in 13.1.0 os7 (still can be a half second or so behind).

comment:7 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.