Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3934 closed defect (fixed)

Browse shows "Loading..." for title of media samples

Reported by: greenfeld Owned by: humitos
Priority: Low Milestone:
Component: Browse Version: 0.97.x
Severity: Unspecified Keywords: r+, olpc-test-passed
Cc: manuq Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Start Browse-140 in OLPC 13.1.0 os2.
  2. Play one of the sample audio files included in the OLPC library.
  3. The title in the URL entry area for the sample will be "Loading..." (or a translation thereof).

Attachments (2)

0001-Don-t-show-error-page-when-plugin-will-handle.patch (1.2 KB) - added by humitos 7 years ago.
0001-Title-of-media-files-SL-3934.patch (1.4 KB) - added by humitos 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by dsd

  • Milestone changed from Unspecified by Release Team to 0.98
  • Owner changed from erikos to manuq
  • Status changed from new to assigned

comment:2 Changed 7 years ago by manuq

  • Owner changed from manuq to humitos

comment:3 Changed 7 years ago by humitos

  • Cc manuq added

After applying the patch attached (that allows the plugin to load properly) it says "Media" in the tab label. Is that OK? What should the tab say?

comment:4 Changed 7 years ago by manuq

Oh, so you found and solved another bug related to the error page, similar to #3972 . Pushed the fix as ce026b96.

This one is not solved yet. Looks like the tab is displaying the previous title, Media in your case. Should say the the filename, like "Tromboon-sample.ogg" .

Changed 7 years ago by humitos

comment:5 Changed 7 years ago by humitos

  • Keywords r? added

I tested this patch in many ways, browsing on:

  • a common page
  • a page without <title>
  • a page handled by a plugin
  • an image (.jpg) page

Please, let me know if there is another case that I should test to be sure that this patch is working properly.

comment:6 Changed 7 years ago by humitos

"Error page when plugin will handle" issue is tracked here: #4045

comment:7 Changed 7 years ago by godiard

  • Priority changed from Unspecified by Maintainer to Low

comment:8 Changed 7 years ago by manuq

  • Keywords r+ olpc-test-pending added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

Great, I have tested it enough here too, pushed 28967561 .

comment:9 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Fixed in Browse-148.

comment:10 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.