Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3909 closed defect (notabug)

Cursor in centre screen does not hide frame

Reported by: tonyforster Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

OS2 Putting the cursor into a corner now toggles the frame, the frame should hide when the cursor is outside the frame

Change History (2)

comment:1 Changed 7 years ago by garycmartin

  • Resolution set to notabug
  • Status changed from new to closed

This will need a release note, but it is an intended new feature, it resolves several existing design issues and an upcoming one: 1) having to keep the cursor in the frame area as you try to navigate to an icon (incredibly frustrating if you have a 'jumpy' cursor); 2) allows you to toggle the frame open/closed with both the cursor or the keyboard (if you opened the frame using the keyboard, you could not use the mouse cursor to close it, and if you used the mouse cursor to open the frame, you could not use the keyboard to close it); 3) for improved touch hardware compatibility the edge swipe gestures (and/or fallback top left onscreen frame button) can be used interchangeably with all other toggle methods.

Please re-open this ticket if you feel this is still a bug that can perhaps be resolved in another way, and thanks for filing, FWIW we did spend some time living with this patch to see which way usability would go, and although there is the initial friction from muscle memory vs. the previous behaviour we quickly found it comfortable and an improvement.

comment:2 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.