Opened 10 years ago

Closed 8 years ago

Last modified 6 years ago

#388 closed defect (fixed)

difficulty coloring highlighted text in Write

Reported by: walter Owned by: benzea
Priority: Normal Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords: undiscoverable
Cc: Eben, godiard Distribution/OS: Unspecified
Bug Status: Assigned

Description

When using the new color selector in Write, the selected text is unselected in the process of manipulating the color panel, so the color is not applied where expected. The old color selector did not have this problem.

Change History (15)

comment:1 Changed 10 years ago by erikos

  • Bug Status changed from Unconfimed to New

Steps to reproduce:

  • Write text
  • Select it
  • switch color

Color is not changed

comment:2 Changed 10 years ago by erikos

  • Component changed from Write to sugar-toolkit
  • Owner set to benzea
  • Status changed from new to assigned

comment:3 Changed 10 years ago by erikos

  • Bug Status changed from New to Assigned

comment:4 Changed 10 years ago by walter

<erikos> walterbender, is my way to reproduce what you meant?
<walterbender> erikos: yes. but with one more detail.
<walterbender> the color you chose is now the color for future typing.
<walterbender> erikos: and sometimes different text gets highlighted while in the dialog: this gets the new color.
<erikos> walterbender, can you comment on the ticket your findings, looks like it is the color picker itself
<walterbender> I think it must be the color picker somehow interacting with text selection

comment:5 Changed 10 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.84
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Major
  • Version changed from Unspecified to Git as of bugdate

comment:6 Changed 10 years ago by tomeu

Tentatively as 0.84 supposing it's easy to fix and bad enough.

comment:7 Changed 10 years ago by benzea

  • Cc Eben added

I don't think we can do much about it. If you click outside of the palette, this button press will have an effect. One could prevent this completely, but that would likely create other issues.

The best thing would likely be to add OK/Cancel buttons to the palette.

comment:8 Changed 10 years ago by erikos

  • Milestone changed from 0.84 to 0.86

Design needed here to be fixed in 0.86

comment:9 Changed 10 years ago by Mokurai

  • Keywords undiscoverable added

The undocumented secret is to make your color selection, then click anywhere on the toolbar. The text remains selected, and is now in the desired color. Added to The undiscoverable? in the Sugarabs Wiki.

comment:10 Changed 10 years ago by garycmartin

From ML thread [Design] Color Button 10th Sept:

Is it possible to emit the colour change event as soon as a colour is clicked? Or, perhaps emit as soon as the mouse leaves the palette area?

I tried some quick mockups, the OK/Cancel doesn't feel very Sugar UI like (no other palettes use this behaviour). The click a colour to dismiss, with the addition of a 'custom colour' icon seems more natural, but looses a current nice feature where by you can pick a preset colour, see the sliders move, and then adjust them if you want to tweak. It also seems a little odd seeing both the toolbar icon and the custom icon changing colour at same time, though I guess in this case the toolbar icon could only change once you make a choice (and as you move a cursor around a document with colours).

Anyway, all this makes me think that solving the issue by emitting colour change events early (i.e. not just when palette closes) would be a cleaner solution (more like a bug fix for a current unintended behaviour rather than redesigning an already good UI to avoid it).

comment:11 Changed 8 years ago by godiard

  • Cc godiard added

Walter, I think this ticket is already resolved, can you confirm?

comment:12 Changed 8 years ago by walter

Seems that you can color highlighted text by selecting a color. The text color changes at that instance. OK to close this ticket AFAIK. Thanks.

comment:13 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:14 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:15 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.