Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3858 closed defect (fixed)

Read claims cbr/cbz support but does not seem to have a handler for it

Reported by: greenfeld Owned by: godiard
Priority: Low Milestone:
Component: Read Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Read claims to support (Comic Book) cbr & cbz files in its activity.info file.

But when one launches a .cbz file in Read nothing appears, although Read does not crash.

The .cbr extension also implies RAR compression according to Wikipedia (http://en.wikipedia.org/wiki/Comic_book_archive) which I do not think OLPC builds include support for.

Tested with the free CBRs (with .cbz extension) at http://www.moderntales.com/

Change History (8)

comment:1 Changed 7 years ago by godiard

  • Cc dsd added

About .cbr, I agree we should remove support.

About .cbz, evince, I have downloaded http://www.moderntales.com/cbr/8/hotelfred_1.cbz and evince can't open it.

But the problem is solved if we install the zip package. (yum install zip)

dsd: can we add it to our image?

comment:2 Changed 7 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98

comment:3 Changed 7 years ago by dsd

I would expect unzip to be sufficient here, which is already included.

comment:5 Changed 7 years ago by godiard

dsd, upstream bug [1] have a explanation about why zip is needed.

I wait a decision here. If we can't include zip, I need remove the mime type.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=685805

comment:6 Changed 7 years ago by godiard

  • Cc dsd removed
  • Priority changed from Unspecified by Maintainer to Low

comment:7 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Removed support of cbr & cbz with 07c85afc5534e7e0322e801e024c85b4b78adb86

Filled #4241 to add support again when dependencies available.

comment:8 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.