Opened 7 years ago

Closed 7 years ago

#3853 closed defect (fixed)

Read: Cannot use dropdown to select location in PG epub books

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Read Version: Unspecified
Severity: Unspecified Keywords: 13.1.0
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Reported by Cerlyn in http://dev.laptop.org/ticket/10495

'In "A Tale of Two Cities" as well as the "The Adventures of Huckleberry Finn" epub books from Project Gutenberg, the drop-down menu in the top of the "Read" menu area does not jump to a selection point.

In the "Pandora's Legions" epub book from the Baen Free Library this works.

Someone needs to figure out who is at fault or if the epub spec is vague.

Tested in 10.1.3 os355. Books tested selected more or less at random.'

"A Tale of Two Cities" can be downloaded from http://www.gutenberg.org/ebooks/98

The error happen, because the links in this books point to internal url in a document, with the form 98/@public@vhost@g@gutenberg@html@files@98@98-h@…#pgepubid00009

Attachments (1)

Aventuras del sapo Ruperto interior - aventura del sapo ruperto - brechner@internet.com.uy.epub (424.4 KB) - added by godiard 7 years ago.
Example of epub file generated in UY

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by godiard

Example of epub file generated in UY

comment:1 Changed 7 years ago by godiard

Another case to test, is the attached file, generated in UY. The link in the index, points to the end of the previous document to the needed chapter.

comment:2 Changed 7 years ago by godiard

Fixed in eafed20bd06a82e1737786da10fa829b1e220b70, will be available in Read 101

comment:3 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.