Opened 9 years ago

Closed 8 years ago

#3799 closed defect (duplicate)

Truly show the "WATCH" (waiting) cursor, during the process a section-view is loaded

Reported by: ajay_garg Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: ajay_garg Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When we click a section-view icon in "My Settings", we should "truly" be shown the waiting cursor, during the duration the section-view is loaded.

Currently, the code is there to show the waiting-cursor; however it does not always take effect, since "realizing" the cursor would happen when the main-thread goes idle.

Instead, it should be the other way around :: first let "realize" the waiting-cursor; after this is done, proceed forward with further actions, by scheduling the further-actions via "gobject.idle_add".

Change History (3)

comment:1 Changed 9 years ago by ajay_garg

Patch (for sugar 0.98, mainline) at ::
http://patchwork.sugarlabs.org/patch/1642/

comment:2 Changed 9 years ago by ajay_garg

  • Cc ajay_garg added

comment:3 Changed 8 years ago by dnarvaez

  • Resolution set to duplicate
  • Status changed from new to closed

DUplicate of #245

Note: See TracTickets for help on using tickets.