Opened 8 years ago

Last modified 4 years ago

#3766 reopened defect

Images are added twice

Reported by: humitos Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: InfoSlicer Version: Unspecified
Severity: Unspecified Keywords: gtk3, screenshot, port
Cc: walter, gonzalo Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce

  1. Open Info Slicer
  2. Go to the edit view
  3. Click on the images icon
  4. Drag and drop an image to the article

Issue

The image is added twice

Expected behaviour

Add the image just once

Environment

Fedora 17, sugar-build, git version of Info Slicer

Attachments (2)

47.png (533.3 KB) - added by humitos 8 years ago.
gtk3-drag-and-drop-example.py (3.1 KB) - added by humitos 8 years ago.
Drag N Drop Gtk3 Example

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by humitos

comment:1 Changed 8 years ago by humitos

  • Component changed from untriaged to InfoSlicer
  • Owner set to humitos
  • Status changed from new to accepted

comment:2 Changed 8 years ago by humitos

I've just attached an example that explains how we are using the Drag And Drop functionality in InfoSlicer.

The problem is that the images are added twice in a TextView and this example shows the same behaviour.

So, I will ask to #gtk people to know if there is something that I'm doing wrong or it's a bug.

The images used in the example are these ones:

Changed 8 years ago by humitos

Drag N Drop Gtk3 Example

comment:5 Changed 8 years ago by humitos

dnarvaez told me that I should remove the line number 85 of the example. After doing that: it worked!

comment:6 Changed 8 years ago by humitos

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:8 Changed 4 years ago by iamutkarshtiwari

  • Resolution fixed deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.