Opened 9 years ago

Closed 9 years ago

#3753 closed defect (fixed)

sugar-network-service fails to resolve API DNS name after becoming online

Reported by: alsroot Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-network Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

The problem is not specific to sugar-network-service. In Fedora-14 environment created by OOB, the following code being launched in offline, still can't resolve DNS names if system became online (after restarting this script in online, it works fine):

import time
import socket

while True:
    try:
        print socket.gethostbyname('sugarlabs.org')
    except Exception, error:
        print error
    time.sleep(1)

Change History (2)

comment:1 Changed 9 years ago by sascha_silbe

See #1940 for a very similar issue in Sugar.

comment:2 Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.