Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3744 closed defect (invalid)

Pango.EllipsizeMode.MIDDLE constant

Reported by: humitos Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos, manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Porting InfoSlicer to Gtk3 I found this error on the sugar-toolkit-gtk3:

    Traceback (most recent call last):
    File "/home/humitos/sugar-jhbuild/install/bin/sugar-activity", line 154, in <module>
    main()
    File "/home/humitos/sugar-jhbuild/install/bin/sugar-activity", line 149, in main
    instance = create_activity_instance(activity_constructor, activity_handle)
    File "/home/humitos/sugar-jhbuild/install/bin/sugar-activity", line 36, in create_activity_instance
    activity = constructor(handle)
    File "/home/humitos/Activities/InfoSlicer.activity/activity.py", line 47, in __init__
    self.instance()
    File "/home/humitos/Activities/InfoSlicer.activity/activity.py", line 56, in instance
    self.library = library.View(self)
    File "/home/humitos/Activities/InfoSlicer.activity/library.py", line 49, in __init__
    _('Wiki'), _('Wiki articles'), False)
    File "/home/humitos/Activities/InfoSlicer.activity/bookview.py", line 102, in __init__
    delete.set_tooltip(_('Delete current article'))
    File "/home/humitos/sugar-jhbuild/install/lib/python2.7/site-packages/sugar3/graphics/toolbutton.py", line 92, in set_tooltip
    self.palette = Palette(tooltip)
    File "/home/humitos/sugar-jhbuild/install/lib/python2.7/site-packages/sugar3/graphics/palette.py", line 104, in __init__
    self._label.set_ellipsize(Pango.EllipsizeMode.MIDDLE)
    AttributeError: type object 'EllipsizeMode' has no attribute 'MIDDLE'

On a Terminal Activity (inside sugar-jhbuild on Fedora 17):

>>> from gi.repository import Pango
>>> Pango.EllipsizeMode.MIDDLE
<enum PANGO_ELLIPSIZE_MIDDLE of type PangoEllipsizeMode>
>>>

I had to comment out those lines (104 and 112 of palette.py) to be able to keep porting the activity.

Attachments (1)

2012-07-04.081140-0300ART.html (15.5 KB) - added by humitos 9 years ago.
Log from #python channel at irc.gimp.net

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by humitos

Log from #python channel at irc.gimp.net

comment:1 Changed 8 years ago by walter

  • Resolution set to invalid
  • Status changed from new to closed

The current version of Infoslicer does not have this problem. I suspect it was due to an incomplete port to Gtk3 at the time this ticket was filed (mixing Gtk2 and Gtk3). Please reopen if the issue comes up again.

comment:2 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar
Note: See TracTickets for help on using tickets.