Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3736 closed defect (fixed)

Sugar toolbar search widget icons are smaller than in original releases

Reported by: garycmartin Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: design
Cc: manuq, godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The sugar toolbar search widget icons are much smaller than the original sugar releases, larger icons are clearer and more easy to click/touch. See attached screen shot showing Sugar 0.96 vs Sugar 0.82 as taken on an XO. The magnifying glass is much thinner and the clear search widget much smaller.

Attachments (2)

Sugar_toolbar_search_icons_are_smaller.png (17.9 KB) - added by garycmartin 7 years ago.
Correct-system-search-icon-stroke-thickness.patch (3.4 KB) - added by garycmartin 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by garycmartin

comment:1 Changed 7 years ago by garycmartin

  • Keywords design added

comment:2 Changed 7 years ago by garycmartin

  • Cc manuq added

manuq, cc:ing you in this design ticket as this may require tweaks in sugar-artwork, but not sure where the issue is – we often seem to have some scaling fun with icons inside other toolbar widgets ;)

comment:3 Changed 7 years ago by garycmartin

  • Cc godiard added

Hmmm, just found sugar-artwork commit 0d668 from Gonzalo, "Modify search icon to honor stroke and fill color", however looking at the diff it's not just the stroke and fill attributes that were added. The stroke was changed from stroke-width="3.5" down to stroke-width="2". So that explains why the search icon has gone all skinny... Gonzalo, was there a reason for the change in stroke? My concern is you might have tweaked it as a fix for an activity that was using that icon as a regular full size toolbarbutton (was in Wikipedia at one point I think), or perhaps just an accidental change?

comment:4 Changed 7 years ago by godiard

Yes, the loupe was changed to show it in a standard toolbar.

Right now Wikipedia use a different icon, then can be changed if needed.

Anyway, should not be the only cause of this error, because the cancel icon is smaller too.

comment:5 Changed 7 years ago by manuq

  • Milestone changed from Unspecified by Release Team to 0.98

Thanks Gary. Confirmed. Setting 0.98 milestone.

comment:6 Changed 7 years ago by garycmartin

  • Component changed from sugar to sugar-artwork
  • Owner changed from erikos to manuq
  • Status changed from new to assigned

Changed 7 years ago by garycmartin

comment:7 Changed 7 years ago by garycmartin

Attached a patch for sugar-artwork that corrects the stroke thickness (and removes some M line endings).

comment:8 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks for the patches Gary. Pushed: 2654221e and 5e132241 .

comment:9 Changed 6 years ago by dnarvaez

  • Component changed from sugar-artwork to Sugar

comment:10 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.